Bug 1288474 - tiering: quota list command is not working after attach or detach
tiering: quota list command is not working after attach or detach
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Manikandan
: ZStream
Depends On: 1287997
Blocks: 1288484
  Show dependency treegraph
 
Reported: 2015-12-04 06:07 EST by Vijaikumar Mallikarjuna
Modified: 2016-06-16 09:48 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1287997
: 1288484 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:48:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-04 06:29:49 EST
REVIEW: http://review.gluster.org/12881 (quota: copy quota_version value in func glusterd_volinfo_dup) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2015-12-09 02:23:14 EST
COMMIT: http://review.gluster.org/12881 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit eb1a6e9f88cfd4c80c6af7260e5e6537cb76b6c0
Author: vmallika <vmallika@redhat.com>
Date:   Fri Dec 4 16:51:18 2015 +0530

    quota: copy quota_version value in func glusterd_volinfo_dup
    
    quota_version is a new variable introduced for
    quota xattr versioning feature.
    
    quota_version was not copied when creating duplicate
    volinfo in function 'glusterd_volinfo_dup'
    so any feature like snapshot/tiering using
    glusterd_volinfo_dup will get the default value
    of quota_version instead of the correct number
    and can cause a problem
    
    Change-Id: I7b0f418002d49aa7210e2e741e65ee5b2593e6a6
    BUG: 1288474
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/12881
    Reviewed-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 3 Vijay Bellur 2015-12-09 04:31:57 EST
REVIEW: http://review.gluster.org/12920 (glusterd: fix broken code by http://review.gluster.org/#/c/12881/ patch) posted (#1) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 4 Vijay Bellur 2015-12-09 04:46:30 EST
REVIEW: http://review.gluster.org/12920 (glusterd: fix broken code by http://review.gluster.org/#/c/12881/ patch) posted (#2) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 7 Niels de Vos 2016-06-16 09:48:40 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.