Bug 1288484 - tiering: quota list command is not working after attach or detach
tiering: quota list command is not working after attach or detach
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.5
x86_64 Linux
unspecified Severity urgent
: 3.7.5
: ---
Assigned To: Vijaikumar Mallikarjuna
: ZStream
Depends On: 1287997 1288474
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-04 06:28 EST by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:48 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1288474
Environment:
Last Closed: 2016-04-19 03:50:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-04 06:33:22 EST
REVIEW: http://review.gluster.org/12882 (quota: copy quota_version value in func glusterd_volinfo_dup) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2015-12-09 02:28:10 EST
COMMIT: http://review.gluster.org/12882 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 9825bbfc75c369a83f8b9e8a467441a8d9039685
Author: vmallika <vmallika@redhat.com>
Date:   Fri Dec 4 16:51:18 2015 +0530

    quota: copy quota_version value in func glusterd_volinfo_dup
    
    This is a backport of http://review.gluster.org/#/c/12881/
    
    quota_version is a new variable introduced for
    quota xattr versioning feature.
    
    quota_version was not copied when creating duplicate
    volinfo in function 'glusterd_volinfo_dup'
    so any feature like snapshot/tiering using
    glusterd_volinfo_dup will get the default value
    of quota_version instead of the correct number
    and can cause a problem
    
    > Change-Id: I7b0f418002d49aa7210e2e741e65ee5b2593e6a6
    > BUG: 1288474
    > Signed-off-by: vmallika <vmallika@redhat.com>
    
    Change-Id: I971d3a4a08805a363bc4ab3c7343afb39916a3cf
    BUG: 1288484
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/12882
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 3 Vijay Bellur 2015-12-09 06:28:52 EST
REVIEW: http://review.gluster.org/12922 (glusterd: fix the build) posted (#2) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 4 Vijay Bellur 2015-12-09 06:30:32 EST
COMMIT: http://review.gluster.org/12922 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 2f4ec1dbfab7e43cd5404d5ebe6073f892541248
Author: Michael Adam <obnox@samba.org>
Date:   Wed Dec 9 09:59:40 2015 +0100

    glusterd: fix the build
    
    This is a backport of http://review.gluster.org/#/c/12918/
    
    Fix the build broken in 6e9f88cfd4c80c6af7260e5e6537cb76b6c0
    
    Change-Id: I0c5cedff980688cb47f3f0e9f4968c23d2f507d3
    BUG: 1288484
    Signed-off-by: Michael Adam <obnox@samba.org>
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/12922
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: Atin Mukherjee <amukherj@redhat.com>
Comment 5 Kaushal 2016-04-19 03:50:07 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.