Bug 1288551 - Provide metrics rollups per projects, services and replicators
Provide metrics rollups per projects, services and replicators
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.3
Assigned To: Federico Simoncelli
Einat Pacifici
container
: ZStream
Depends On: 1288489 1321561
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-04 09:39 EST by John Prause
Modified: 2017-05-08 10:45 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1288489
Environment:
Last Closed: 2016-04-13 14:39:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Services metrics (845.83 KB, image/png)
2016-01-28 05:47 EST, Avi Tal
no flags Details
Projects metrics (847.01 KB, image/png)
2016-01-28 05:47 EST, Avi Tal
no flags Details
Replicators metrics (854.33 KB, image/png)
2016-01-28 05:48 EST, Avi Tal
no flags Details

  None (edit)
Comment 5 Avi Tal 2016-01-28 05:46:19 EST
Build 5.5.2.2
I have ran "cat /dev/zero > /dev/null" inside my container but with the current CPU Used Graphs i can't really estimate what is the right CPU usage.

CPU Used graph scope is 0!
See screenshots
Comment 6 Avi Tal 2016-01-28 05:47 EST
Created attachment 1119091 [details]
Services metrics
Comment 7 Avi Tal 2016-01-28 05:47 EST
Created attachment 1119093 [details]
Projects metrics
Comment 8 Avi Tal 2016-01-28 05:48 EST
Created attachment 1119094 [details]
Replicators metrics
Comment 10 Federico Simoncelli 2016-02-02 09:32:21 EST
We need the screenshots of the relevant pod and container CPU load (to verify that it was picked up) and the proof that the pod was referenced by those services and replicators.

Feel free to ping me and we'll walk through this together. Thanks!
Comment 11 Federico Simoncelli 2016-02-04 11:07:46 EST
I just verified this upstream, and it works as expected.

Unless there's a weird issue downstream, I suspect that we have to re-verify this BZ properly (and move it back to Fixed In Version: 5.5.2.1).

Avi, can you please contact me to re-verify this together? Thanks.
Comment 15 Barak 2016-04-03 06:01:35 EDT
Einat,

IIUC (after talking to Fede) than the above bugs are not the ones preventing you from verifying this issue.

Can you please share the problem you are having, 
And specify the exact versions of the components you are using.
- Open Shift
- atomic-openshift-utils
- The versions of each POD you are running the metrics with.
Comment 16 Barak 2016-04-03 08:35:21 EDT
After debug with Einat,
It looks like her environment used the latest Hawkular image (instead of 3.1),
She is now redeploying it to see if we have a real problem ... or to verify this bug.
Comment 17 Federico Simoncelli 2016-04-11 03:30:00 EDT
The target-release and fixed-in-version of this bug are wrong.

This was fixed in 5.5.2.1 (past December/January).
Comment 19 errata-xmlrpc 2016-04-13 14:39:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.