Bug 1288992 - Possible memory leak in the tiered daemon
Possible memory leak in the tiered daemon
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
: ZStream
Depends On: 1285998 1288019
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 02:58 EST by Joseph Elwin Fernandes
Modified: 2016-04-19 03:50 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1288019
Environment:
Last Closed: 2016-04-19 03:50:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-07 02:59:57 EST
REVIEW: http://review.gluster.org/12889 (tier/dht: Fix mem leak from lookup response dict) posted (#1) for review on release-3.7 by Joseph Fernandes
Comment 2 Vijay Bellur 2015-12-09 12:30:40 EST
COMMIT: http://review.gluster.org/12889 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 117dce7a489624ad7a7ab6b9299b3e2c1aa0bab6
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Thu Dec 3 15:40:16 2015 +0530

    tier/dht: Fix mem leak from lookup response dict
    
    Fixing memory leak from response dict during a parent
    lookup to get the path.
    
    Backport of http://review.gluster.org/12867
    
    > Change-Id: I60c23d0b25e7f763f0e53c40e71ee053aba6d555
    > BUG: 1288019
    > Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    > Reviewed-on: http://review.gluster.org/12867
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Joseph Fernandes
    > Tested-by: Joseph Fernandes
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    
    Change-Id: I77dfbb097e0200ace4c1adcf48560caf283007d7
    BUG: 1288992
    Reviewed-on: http://review.gluster.org/12889
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2016-04-19 03:50:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.