Bug 1289031 - RFE:nfs-ganesha:prompt the nfs-ganesha disable cli to let user provide "yes or no" option
RFE:nfs-ganesha:prompt the nfs-ganesha disable cli to let user provide "yes o...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: ganesha-nfs (Show other bugs)
3.7.7
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jiffin
: EasyFix, FutureFeature, Triaged
Depends On: 1277828
Blocks: 1289039 1364382
  Show dependency treegraph
 
Reported: 2015-12-07 04:32 EST by Jiffin
Modified: 2016-08-05 04:52 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1277828
: 1289039 1364382 (view as bug list)
Environment:
Last Closed: 2016-04-19 03:24:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-07 05:06:00 EST
REVIEW: http://review.gluster.org/12892 (cli : provide prompt for the nfs-ganesha disable cli) posted (#1) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 2 Vijay Bellur 2016-02-16 01:23:02 EST
REVIEW: http://review.gluster.org/12892 (cli : provide prompt for the nfs-ganesha disable cli) posted (#2) for review on master by jiffin tony Thottan (jthottan@redhat.com)
Comment 3 Vijay Bellur 2016-02-16 01:43:05 EST
REVIEW: http://review.gluster.org/13450 (cli : provide prompt for the nfs-ganesha disable cli) posted (#1) for review on release-3.7 by jiffin tony Thottan (jthottan@redhat.com)
Comment 4 Vijay Bellur 2016-02-19 00:41:44 EST
REVIEW: http://review.gluster.org/13450 (cli : provide prompt for the nfs-ganesha disable cli) posted (#2) for review on release-3.7 by jiffin tony Thottan (jthottan@redhat.com)
Comment 5 Vijay Bellur 2016-02-22 07:46:18 EST
COMMIT: http://review.gluster.org/13450 committed in release-3.7 by Niels de Vos (ndevos@redhat.com) 
------
commit c2462200ac3c3d49992561f2c9dd0fc55d1300c1
Author: jiffin tony thottan <jthottan@redhat.com>
Date:   Mon Dec 7 14:38:54 2015 +0530

    cli : provide prompt for the nfs-ganesha disable cli
    
    Presently, when we are executing the command "gluster nfs-ganesha disable",
    the disable of nfs-ganesha cluster starts working whereas, in some cases
    the user may not want to disable the cluster. So we shall let him know by
    giving a prompt to let him say "yes or no" for going ahead with the disable
    procedures.
    
    Change-Id: I860dad1479f7ca16bc2736b8056b609473bef65f
    BUG: 1289031
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/13450
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 6 Kaushal 2016-04-19 03:24:20 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.