Bug 1277828 - RFE:nfs-ganesha:prompt the nfs-ganesha disable cli to let user provide "yes or no" option
RFE:nfs-ganesha:prompt the nfs-ganesha disable cli to let user provide "yes o...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-nfs (Show other bugs)
3.1
x86_64 Linux
unspecified Severity medium
: ---
: RHGS 3.1.3
Assigned To: Jiffin
Shashank Raj
: FutureFeature, ZStream
Depends On:
Blocks: 1289031 1289039 1311386 1320424 1364382
  Show dependency treegraph
 
Reported: 2015-11-04 03:08 EST by Saurabh
Modified: 2016-11-07 22:53 EST (History)
11 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9-1
Doc Type: Enhancement
Doc Text:
Previously when users ran the 'gluster nfs-ganesha disable' command, nfs-ganesha would be disabled immediately. This command now prompts users for confirmation that the nfs-ganesha cluster should be disabled after this command is run.
Story Points: ---
Clone Of:
: 1289031 (view as bug list)
Environment:
Last Closed: 2016-06-23 00:56:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1240 normal SHIPPED_LIVE Red Hat Gluster Storage 3.1 Update 3 2016-06-23 04:51:28 EDT

  None (edit)
Description Saurabh 2015-11-04 03:08:34 EST
Description of problem:

  Presently, when we are executing the command "gluster nfs-ganesha disable", the disable of nfs-ganesha cluster starts working. 
  Whereas, in some cases the customer may not want to disable the cluster so we shall let him be judicious by giving a prompt to let him say "yes or no" for going ahead with the disable mechanism.


Version-Release number of selected component (if applicable):
glusterfs-3.7.5-5.el7rhgs.x86_64
nfs-ganesha-2.2.0-10.el7rhgs.x86_64

How reproducible:
always


Actual results:
# gluster nfs-ganesha disable
This will take a few minutes to complete. Please wait ..
nfs-ganesha : success 


Expected results:
Prompt it to say yes or no, to move ahead accordingly.

Additional info:
Comment 4 Mike McCune 2016-03-28 18:50:27 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 5 Shashank Raj 2016-03-29 08:24:15 EDT
Verified this bug with latest build 3.7.9-1 and its working as expected.

[root@dhcp46-247 exports]# rpm -qa|grep glusterfs
glusterfs-3.7.9-1.el7rhgs.x86_64
glusterfs-api-3.7.9-1.el7rhgs.x86_64
glusterfs-cli-3.7.9-1.el7rhgs.x86_64
glusterfs-fuse-3.7.9-1.el7rhgs.x86_64
glusterfs-geo-replication-3.7.9-1.el7rhgs.x86_64
glusterfs-libs-3.7.9-1.el7rhgs.x86_64
glusterfs-ganesha-3.7.9-1.el7rhgs.x86_64
glusterfs-rdma-3.7.9-1.el7rhgs.x86_64
glusterfs-client-xlators-3.7.9-1.el7rhgs.x86_64
glusterfs-server-3.7.9-1.el7rhgs.x86_64

[root@dhcp46-247 exports]# rpm -qa|grep ganesha
nfs-ganesha-gluster-2.3.1-1.el7rhgs.x86_64
glusterfs-ganesha-3.7.9-1.el7rhgs.x86_64
nfs-ganesha-2.3.1-1.el7rhgs.x86_64

Whenever we execute, gluster nfs-ganesha disable, it prompts the user with (y/n) option.


[root@dhcp46-247 exports]# gluster nfs-ganesha disable
Disabling NFS-Ganesha will tear down entire ganesha cluster across the trusted pool. Do you still want to continue?
 (y/n) y
This will take a few minutes to complete. Please wait ..
nfs-ganesha : success

Based on the above observation marking this bug as Verified.
Comment 7 Jiffin 2016-06-14 01:02:09 EDT
Doc text looks good to me.
Comment 9 errata-xmlrpc 2016-06-23 00:56:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1240

Note You need to log in before you can comment on or make changes to this bug.