Bug 1289067 - [RFE][UX] visual separation of autoremoved packages
[RFE][UX] visual separation of autoremoved packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
: EasyFix, FutureFeature, Reopened, Triaged
: 1316048 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 06:32 EST by Michal Luscon
Modified: 2016-10-04 15:15 EDT (History)
6 users (show)

See Also:
Fixed In Version: dnf-2.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-04 15:15:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Luscon 2015-12-07 06:32:22 EST
Example of the output:

$ dnf remove ekiga
Dependencies resolved.
=============================================================
Removing:
 ekiga                 x86_64 4.0.1-17.fc22   @fedora   19 M
Removing unused dependencies:
 evolution-data-server x86_64 3.16.5-1.fc22   @updates  14 M
 geocode-glib          x86_64 3.16.2-1.fc22   @fedora  160 k
 gnome-online-accounts x86_64 3.16.4.1-1.fc22 @updates 4.0 M
 libgdata              x86_64 0.17.3-1.fc22   @updates 1.7 M
Comment 1 Michal Luscon 2016-03-14 09:04:39 EDT
*** Bug 1316048 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Admin XMLRPC Client 2016-07-08 05:24:56 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Honza Silhan 2016-08-02 04:38:24 EDT
I believe this is implemented in the upstream.
Comment 4 Jan Pazdziora 2016-08-02 05:04:58 EDT
Reopening -- dnf-2.0 is not available in https://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/Everything/x86_64/os/Packages/d/ -- there is still only dnf-1.1.9-3.fc25.noarch.rpm there.

Per https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow#CLOSED the bugzilla should be CLOSED when the fix is available in rawhide or the updates repo.

Maybe you meant to use POST?
Comment 5 Igor Gnatenko 2016-08-02 05:11:06 EDT
We use RHBZ to track upstream issues. DNF 2.0 will be available very soon.
Comment 6 Jan Pazdziora 2016-08-02 07:46:11 EDT
This is great. But this was filed against Fedora rawhide, the problem is present in Fedora rawhide, people saw this bugzilla and did not file a duplicate one because they expected proper Fedora handling.

You cannot just come and start claiming that Fedora guidelines do not apply here.

Note You need to log in before you can comment on or make changes to this bug.