Bug 1316048 - dnf remove does not make it possible to distinguish dependencies removed from requirements cleaned
dnf remove does not make it possible to distinguish dependencies removed from...
Status: CLOSED DUPLICATE of bug 1289067
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 05:23 EST by Jan Pazdziora
Modified: 2016-03-14 09:04 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-14 09:04:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2016-03-09 05:23:16 EST
Description of problem:

When running dnf remove with the default

   clean_requirements_on_remove=True

set, the package specified and a bunch of other packages is scheduled for removal. It is not obvious from the output why those packages are there -- whether they are packages that depend (even transitively) from what is being requested for removal, or whether they are "leaf" packages that are cleaned.

Version-Release number of selected component (if applicable):

dnf-1.1.6-2.fc23.noarch

How reproducible:

Deterministic.

Steps to Reproduce:
1. dnf install -y docker
2. dnf install -y atomic
3. dnf remove docker

Actual results:

Dependencies resolved.
=========================================================================
 Package            Arch   Version       Repository                 Size
=========================================================================
Removing:
 atomic             x86_64 1.8-3.gitcc5997a.fc23
                                         @updates                  2.1 M
 audit-libs-python3 x86_64 2.4.5-1.fc23  @updates                  465 k
 checkpolicy        x86_64 2.4-1.fc23.1  @beaker-Fedora-Everything 1.0 M
 docker             x86_64 1:1.9.1-6.git6ec29ef.fc23
                                         @updates                   38 M
 docker-selinux     x86_64 1:1.9.1-6.git6ec29ef.fc23
                                         @updates                   25 k
 libcgroup          x86_64 0.41-7.fc23   @beaker-Fedora-Everything 129 k
 libsemanage-python3
                    x86_64 2.4-4.fc23    @beaker-Fedora-Everything 371 k
 policycoreutils-python-utils
                    x86_64 2.4-20.fc23   @updates                  130 k
 policycoreutils-python3
                    x86_64 2.4-20.fc23   @updates                  2.7 M
 python-IPy-python3 noarch 0.81-13.fc23  @beaker-Fedora-Everything 137 k
 python3-docker-py  noarch 1.5.0-1.fc23  @updates                  205 k
 python3-requests   noarch 2.9.1-1.fc23  @updates                  346 k
 python3-urllib3    noarch 1.13.1-3.fc23 @updates                  392 k
 python3-websocket-client
                    noarch 0.32.0-1.fc23 @beaker-Fedora-Everything 198 k
 setools-libs       x86_64 3.3.8-8.fc23  @updates                  1.5 M
 sqlite             x86_64 3.11.0-2.fc23 @updates                  942 k
 tar                x86_64 2:1.28-6.fc23 @beaker-Fedora-Everything 3.0 M

Transaction Summary
=========================================================================
Remove  17 Packages

Expected results:

Dependencies resolved.
=========================================================================
 Package            Arch   Version       Repository                 Size
=========================================================================
Removing:
 docker             x86_64 1:1.9.1-6.git6ec29ef.fc23
                                         @updates                   38 M
Removing dependendent packages:
 atomic             x86_64 1.8-3.gitcc5997a.fc23
                                         @updates                  2.1 M
 docker-selinux     x86_64 1:1.9.1-6.git6ec29ef.fc23
                                         @updates                   25 k
Removing no longer required packages (clean_requirements_on_remove=True):
 audit-libs-python3 x86_64 2.4.5-1.fc23  @updates                  465 k
 checkpolicy        x86_64 2.4-1.fc23.1  @beaker-Fedora-Everything 1.0 M
 libcgroup          x86_64 0.41-7.fc23   @beaker-Fedora-Everything 129 k
 libsemanage-python3
                    x86_64 2.4-4.fc23    @beaker-Fedora-Everything 371 k
 policycoreutils-python-utils
                    x86_64 2.4-20.fc23   @updates                  130 k
 policycoreutils-python3
                    x86_64 2.4-20.fc23   @updates                  2.7 M
 python-IPy-python3 noarch 0.81-13.fc23  @beaker-Fedora-Everything 137 k
 python3-docker-py  noarch 1.5.0-1.fc23  @updates                  205 k
 python3-requests   noarch 2.9.1-1.fc23  @updates                  346 k
 python3-urllib3    noarch 1.13.1-3.fc23 @updates                  392 k
 python3-websocket-client
                    noarch 0.32.0-1.fc23 @beaker-Fedora-Everything 198 k
 setools-libs       x86_64 3.3.8-8.fc23  @updates                  1.5 M
 sqlite             x86_64 3.11.0-2.fc23 @updates                  942 k
 tar                x86_64 2:1.28-6.fc23 @beaker-Fedora-Everything 3.0 M

Transaction Summary
=========================================================================
Remove  17 Packages

Additional info:
Comment 1 Michal Luscon 2016-03-14 09:04:39 EDT

*** This bug has been marked as a duplicate of bug 1289067 ***

Note You need to log in before you can comment on or make changes to this bug.