Bug 1289097 - neutron_url is missing from controller-puppet.yaml
neutron_url is missing from controller-puppet.yaml
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity urgent
: y2
: 7.0 (Kilo)
Assigned To: Giulio Fidente
Marius Cornea
:
: 1289342 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 07:38 EST by Marius Cornea
Modified: 2015-12-21 11:54 EST (History)
9 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.6-91.el7ost
Doc Type: Bug Fix
Doc Text:
Due to a missing parameter in the Controller configuration Heat template, the director sets the neutron_url to the default value (127.0.0.1) instead of the internal_api_virtual_ip. This fix includes the parameter in the Heat template. Now the director sets neutron_url accordingly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 11:54:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Cornea 2015-12-07 07:38:41 EST
Description of problem:
neutron_url is missing from controller-puppet.yaml and this results in the neutron url set to http://127.0.0.1:9696 in nova.conf

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.6-87.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Update from 7.1 to 7.2 
2. Check /etc/nova/nova.conf for the url in the neutron section

Actual results:
url=http://127.0.0.1:9696

Expected results:
url=http://172.16.20.10:9696

where 172.16.20.10 is the internal_api_virtual_ip

Additional info:
The following is missing from the 7.2 templates compared to the 7.1 puppet/controller-puppet.yaml

neutron_url:
  list_join:
    - ''
    - - 'http://'
      - {get_param: NeutronApiVirtualIP}
      - ':9696'
Comment 4 Alexander Chuzhoy 2015-12-07 17:00:46 EST
workaround for the issue:

Correct the url in /etc/nova/nova.conf
run 'pcs resource restart openstack-nova-api'
Comment 5 Alexander Chuzhoy 2015-12-07 17:01:28 EST
*** Bug 1289342 has been marked as a duplicate of this bug. ***
Comment 6 Alexander Chuzhoy 2015-12-07 18:48:13 EST
Note re comment #4, this will just allow running nova commands and overcome on the error reported here: https://bugzilla.redhat.com/show_bug.cgi?id=1289342.
Comment 17 Marius Cornea 2015-12-12 15:00:17 EST
openstack-tripleo-heat-templates-0.8.6-92.el7ost.noarch

[root@overcloud-compute-0 heat-admin]# crudini --get /etc/nova/nova.conf neutron url
http://172.16.20.10:9696
Comment 19 errata-xmlrpc 2015-12-21 11:54:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2651

Note You need to log in before you can comment on or make changes to this bug.