Bug 1289191 - Create stats socket for haproxy [NEEDINFO]
Create stats socket for haproxy
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
medium Severity unspecified
: Upstream M3
: 11.0 (Ocata)
Assigned To: RHOS Maint
nlevinki
: FutureFeature, InstallerIntegration, Triaged
: 1289192 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 11:06 EST by Ryan O'Hara
Modified: 2017-05-17 15:25 EDT (History)
15 users (show)

See Also:
Fixed In Version: puppet-tripleo-6.1.0-0.20170128003046.875a9f9.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-17 15:25:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
michele: needinfo? (rohara)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 387093 None None None 2016-10-16 16:00 EDT

  None (edit)
Description Ryan O'Hara 2015-12-07 11:06:12 EST
RHEL OSP Director should configue haproxy such that a UNIX domain socket (stats socket) is available to collect information about haproxy. This would be useful for sosreports.

To do this, simply add two lines to the "global" section of haproxy.cfg:

global
    ....
    stats socket /var/run/haproxy.sock mode 600 level user
    stats timeout 2m

Note that this socket is set to "user" level, so this socket is limited to read-only. The "stats timeout" line is optional, but since the default timeout of the stats socket is 10s, we should set this higher.
Comment 2 Mike Burns 2015-12-07 11:10:59 EST
*** Bug 1289192 has been marked as a duplicate of this bug. ***
Comment 4 Mike Burns 2016-04-07 17:00:12 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 6 Michele Baldessari 2016-10-22 04:06:40 EDT
Hi Ryan,

so the review attached here produces the following global section:
global
  daemon  
  group  haproxy
  log  /dev/log local0
  maxconn  20480
  pidfile  /var/run/haproxy.pid
  ssl-default-bind-ciphers  !SSLv2:kEECDH:kRSA:kEDH:kPSK:+3DES:!aNULL:!eNULL:!MD5:!EXP:!RC4:!SEED:!IDEA:!DES
  ssl-default-bind-options  no-sslv3
  stats  socket /var/run/haproxy.sock mode 600 level user
  stats  timeout 2m
  user  haproxy

Do we need to add any docs in tripleo as to how to use this or anything else at all? What do you think?

Thanks,
Michele
Comment 8 Thierry Vignaud 2017-02-14 12:25:43 EST
The change is in puppet-tripleo-6.1.0-0.20170128003046.875a9f9.el7ost
Comment 10 Udi Shkalim 2017-02-20 07:28:28 EST
Verified: puppet-tripleo-6.1.0-0.20170213204914.bb53435.el7ost.noarch
Comment 12 errata-xmlrpc 2017-05-17 15:25:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245

Note You need to log in before you can comment on or make changes to this bug.