Bug 1289192 - Create stats socket for haproxy
Create stats socket for haproxy
Status: CLOSED DUPLICATE of bug 1289191
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
medium Severity medium
: ---
: 8.0 (Liberty)
Assigned To: chris alfonso
Depends On:
  Show dependency treegraph
Reported: 2015-12-07 11:06 EST by Ryan O'Hara
Modified: 2016-04-18 02:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-12-07 11:10:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ryan O'Hara 2015-12-07 11:06:42 EST
RHEL OSP Director should configue haproxy such that a UNIX domain socket (stats socket) is available to collect information about haproxy. This would be useful for sosreports.

To do this, simply add two lines to the "global" section of haproxy.cfg:

    stats socket /var/run/haproxy.sock mode 600 level user
    stats timeout 2m

Note that this socket is set to "user" level, so this socket is limited to read-only. The "stats timeout" line is optional, but since the default timeout of the stats socket is 10s, we should set this higher.
Comment 2 Mike Burns 2015-12-07 11:10:59 EST

*** This bug has been marked as a duplicate of bug 1289191 ***

Note You need to log in before you can comment on or make changes to this bug.