Bug 1289241 - RHEL7.2 - kdelibs: macros.kdelibs4 includes bad %kde_runtime_requires macro
RHEL7.2 - kdelibs: macros.kdelibs4 includes bad %kde_runtime_requires macro
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kdelibs (Show other bugs)
7.2
All Linux
high Severity medium
: rc
: 7.3
Assigned To: Jan Grulich
Desktop QE
: ZStream
Depends On:
Blocks: epel7aarch64 1292257 1304702
  Show dependency treegraph
 
Reported: 2015-12-07 13:03 EST by Rex Dieter
Modified: 2016-11-05 13:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1304702 (view as bug list)
Environment:
Last Closed: 2016-11-05 13:58:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2015-12-07 13:03:37 EST
rpm -q kdelibs
kdelibs-4.14.8-4.el7.x86_64


/usr/lib/rpm/macros.d/macros.kdelibs4 contains:

%kde_applications_version 15.04.1

%kde_runtime_requires \
Requires: kde-runtime >= %{kde_applications_version} \
%{nil}


Problem is that el7 currently only has kde-runtime-4.10.5

so, any application trying to use %kde_runtime_requires will get a broken dependency.

Probably best to make the dep match 4.10.5

%kde_runtime_requires \
Requires: kde-runtime >= 4.10.5 \
%{nil}

or be unversioned

%kde_runtime_requires \
Requires: kde-runtime \
%{nil}
Comment 1 Yaakov Selkowitz 2015-12-16 14:17:12 EST
This breaks any KDE packages built with RHEL 7.2, and therefore should be fixed in 7.2.z as well ASAP.
Comment 3 Jan Grulich 2016-02-02 16:03:10 EST
Fix commited to y-stream branch (rhel-7.3).
Comment 6 Yaakov Selkowitz 2016-11-04 15:46:34 EDT
RHEL 7.3 shipped with kdelibs-4.14.8-5.el7_2, which includes this fix.  Can this now be closed?

Note You need to log in before you can comment on or make changes to this bug.