Bug 1304702 - RHEL7.2 - kdelibs: macros.kdelibs4 includes bad %kde_runtime_requires macro [rhel-7.2.z]
RHEL7.2 - kdelibs: macros.kdelibs4 includes bad %kde_runtime_requires macro [...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kdelibs (Show other bugs)
7.2
All Linux
high Severity medium
: rc
: ---
Assigned To: Jan Grulich
Desktop QE
: ZStream
Depends On: 1289241
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-04 07:13 EST by Marcel Kolaja
Modified: 2016-03-31 18:03 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: When building a package using %kde_runtime_requires macro from macros.kdelibs4. Consequence: The required version of kde-runtime (from expanded %kde_runtime_requires macro) was higher than available kde-runtime version available in RHEL. Fix: The required version of kde-runtime was set to latest available version in RHEL. Result: You can now safely use %kde_runtime_requires macro in your spec files to have dependency on kde-runtime.
Story Points: ---
Clone Of: 1289241
Environment:
Last Closed: 2016-03-31 18:03:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcel Kolaja 2016-02-04 07:13:27 EST
This bug has been copied from bug #1289241 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 3 Jan Grulich 2016-02-04 07:28:12 EST
Fixed in kdelibs-4.14.8-5.el7_2.
Comment 7 errata-xmlrpc 2016-03-31 18:03:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0542.html

Note You need to log in before you can comment on or make changes to this bug.