Bug 1289256 - New Angular wizard not working in RHEL OpenStack
New Angular wizard not working in RHEL OpenStack
Status: CLOSED DUPLICATE of bug 1282765
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: ---
: 7.0 (Kilo)
Assigned To: Matthias Runge
Ido Ovadia
: Triaged, Unconfirmed, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 13:35 EST by Jeremy
Modified: 2018-02-08 06:05 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-08 05:32:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy 2015-12-07 13:35:27 EST
Description of problem:

OpenStack Kilo is supposed to have a new angular wizard for launching an instance. This doesn't seem to work with the RHEL version of OpenStack...

Reference:
https://wiki.openstack.org/wiki/ReleaseNotes/Kilo#OpenStack_Dashboard_.28Horizon.29
Launch Instance Wizard (beta) -- A full replacement for the launch instance workflow has been implemented in AngularJS to address usability issues in the existing launch instance workflow. Due to the late inclusion date and limited testing, this feature is marked as beta for Kilo and not enabled by default. To use the new workflow, the following change to local_settings.py is required: LAUNCH_INSTANCE_NG_ENABLED = True. Additionally, you can disable the default launch instance wizard with the following: LAUNCH_INSTANCE_LEGACY_ENABLED = False. This new work is a view into future development in Horizon.

Enabled this by changing /etc/openstack-dashboard/local_settings

LAUNCH_INSTANCE_NG_ENABLED = True
LAUNCH_INSTANCE_LEGACY_ENABLED = False

Restarted httpd-clone resource. Unfortunate now when clicking on Launch Instance I get a popup which is blank. JS console shows error:

Failed to load resource: the server responded with a status of 404 (Not Found)
76adef98ad14.js:1205 Error: [$compile:tpload] Failed to load template: /static/angular/wizard/wizard.html
http://errors.angularjs.org/1.3.7/$compile/tpload?p0=%2Fstatic%2Fangular%2Fwizard%2Fwizard.html
    at 76adef98ad14.js:674
    at handleError (76adef98ad14.js:1393)
    at processQueue (76adef98ad14.js:1301)
    at 76adef98ad14.js:1302
    at Scope.$eval (76adef98ad14.js:1339)
    at Scope.$digest (76adef98ad14.js:1335)
    at Scope.$apply (76adef98ad14.js:1340)
    at done (76adef98ad14.js:1117)
    at completeRequest (76adef98ad14.js:1134)
    at XMLHttpRequest.requestLoaded (76adef98ad14.js:1128)


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Matthias Runge 2015-12-08 02:37:53 EST
Lots of the new angular stuff does not work, this is why we don't enable this by default.

A fix was merged lately, and I will cherry-pick the fix.
Comment 3 Matthias Runge 2015-12-08 02:38:19 EST
Lots of the new angular stuff does not work, this is why we don't enable this by default.

A fix was merged lately, and I will cherry-pick the fix.
Comment 7 Matthias Runge 2015-12-08 05:32:13 EST

*** This bug has been marked as a duplicate of bug 1282765 ***
Comment 8 Matthias Runge 2015-12-08 06:02:01 EST
A bugfix for this has been included as part of rhbz#1282765

Note You need to log in before you can comment on or make changes to this bug.