Bug 1289259 - Kickstart does not handle bad repository gracefully
Kickstart does not handle bad repository gracefully
Status: CLOSED DUPLICATE of bug 1271657
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 13:42 EST by W. Michael Petullo
Modified: 2016-02-25 04:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-25 04:11:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kickstart script (5.55 KB, text/x-matlab)
2015-12-07 13:42 EST, W. Michael Petullo
no flags Details
Anaconda log (6.46 KB, text/plain)
2015-12-07 13:46 EST, W. Michael Petullo
no flags Details
anaconda-tb file (332.87 KB, text/plain)
2015-12-08 13:06 EST, W. Michael Petullo
no flags Details

  None (edit)
Description W. Michael Petullo 2015-12-07 13:42:54 EST
Created attachment 1103333 [details]
Kickstart script

Description of problem:
I have a Kickstart script which I have used to install many versions of Fedora. I have found that this script no longer works with Fedora 23.

Version-Release number of selected component (if applicable):
Fedora 23's anaconda

How reproducible:
Every time

Steps to Reproduce:
Try to install Fedora 23 using the kickstart script and the network install image.

Actual results:
Anaconda fails with:

Traceback (most recent call first):
  File "/usr/lib64/python3.4/site-packages/pyanaconda/packaging/dnfpayload.py", line 550, in spaceRequired
    for (key, val) in self.storage.mountpoints.items():
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/space.py", line 76, in check
    needed = self.payload.spaceRequired
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/tui/hubs/summary.py", line 79, in prompt
    if self._checker and not self._checker.check():
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 346, in _mainloop
    prompt = last_screen.prompt(self._screens[-1][1])
AttributeError: 'NoneType' object has no attribute 'mountpoints'

Expected results:
Fedora 23 should install according to the Kickstart script.

Additional info:
Other log files and Kickstart script attached.
Comment 1 W. Michael Petullo 2015-12-07 13:46 EST
Created attachment 1103334 [details]
Anaconda log
Comment 2 W. Michael Petullo 2015-12-07 16:09:28 EST
After further study, this seems to be due to some of the repositories listed in the Kickstart script being unavailable. I think this could be handled more gracefully so that the administrator gets a more useful error message.
Comment 3 Chris Lumens 2015-12-07 16:28:50 EST
Please attach the complete /tmp/anaconda-tb-* file to this bug report.  Thanks.
Comment 4 W. Michael Petullo 2015-12-08 13:06 EST
Created attachment 1103659 [details]
anaconda-tb file
Comment 5 Alexander Todorov 2016-02-25 04:11:51 EST

*** This bug has been marked as a duplicate of bug 1271657 ***

Note You need to log in before you can comment on or make changes to this bug.