Bug 1271657 - Misleading error on empty repodata: "AttributeError: 'NoneType' object has no attribute 'mountpoints'"
Misleading error on empty repodata: "AttributeError: 'NoneType' object has no...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Konecny
Fedora Extras Quality Assurance
:
: 1289259 1294700 1304480 1314095 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 08:45 EDT by Marian Csontos
Modified: 2016-03-26 14:14 EDT (History)
10 users (show)

See Also:
Fixed In Version: anaconda-24.14-1 anaconda-24.13.1-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-26 14:14:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-tb (190.99 KB, text/plain)
2015-10-27 05:11 EDT, Marian Csontos
no flags Details
kickstart (9.56 KB, text/plain)
2015-10-27 05:12 EDT, Marian Csontos
no flags Details
Tarball with logs (70.18 KB, application/x-gzip)
2015-10-27 05:13 EDT, Marian Csontos
no flags Details

  None (edit)
Description Marian Csontos 2015-10-14 08:45:24 EDT
Description of problem:

I have run into the following error:

    anaconda 23.19.6-1 exception report^M
    Traceback (most recent call first):^M
      File "/usr/lib64/python3.4/site-packages/pyanaconda/packaging/dnfpayload.py", line 550, in spaceRequired^M                          
        for (key, val) in self.storage.mountpoints.items():^M
      File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/lib/space.py", line 76, in check^M
        needed = self.payload.spaceRequired^M
      File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/tui/hubs/summary.py", line 79, in prompt^M
        if self._checker and not self._checker.check():^M
      File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 346, in _mainloop^M
        prompt = last_screen.prompt(self._screens[-1][1])^M
    AttributeError: 'NoneType' object has no attribute 'mountpoints'^M

The `mountpoints' suggests there may be something wrong with storage
configuration. Only after a while trying to understand whether there is
something wrong with my kickstart I have found the mirror is corrupted (empty
repodata.)

There is dnf mentioned in the backtrace but the message is IMO not very helpful.

After switching to correct mirror I was able to proceed with installation.

For completeness, this ks installation using following to configure storage:

    # Partition clearing information
    clearpart --all --initlabel --drives=vda                                                                                              
    # Clear the Master Boot Record
    zerombr
    ignoredisk --only-use=vda,vdb
    # System bootloader configuration
    bootloader --location=mbr --boot-drive=vda --append="console=tty0 console=ttyS1,115200 sysrq_always_enabled"
    # Precisely define partitions:
    part /boot --size=512 --fstype=ext4 --ondisk=vda
    part swap --size=256 --ondisk=vda
    
    logvol / --vgname=vg_stacker_D8F4 --name=root --useexisting --fstype=ext4 --size=6144 --mkfsoptions="-O '^64bit'"

The disk layout has one LV, PV (vdb) is directly on disk, no partitions used:

    NAME                   MAJ:MIN RM    SIZE RO TYPE MOUNTPOINT
    vda                    252:0    0     1G  0 disk 
    vdb                    252:16   0     8G  0 disk 
    `-vg_stacker_D8F4-root 253:2    0     6G  0 lvm  
    loop0                    7:0    0   343M  1 loop 
    loop1                    7:1    0     2G  1 loop 
    |-live-rw              253:0    0     2G  0 dm   /
    `-live-base            253:1    0     2G  1 dm   
    loop2                    7:2    0   512M  0 loop 
    `-live-rw              253:0    0     2G  0 dm   /
    zram0                  251:0    0 993.5M  0 disk [SWAP]

Version-Release number of selected component (if applicable):
Fedora 23_TC9 compose, Server
anaconda 23.19.6-1
Comment 1 David Shea 2015-10-23 13:43:41 EDT
Please attach the logs from /tmp as individual, text/plain attachments.
Comment 2 Marian Csontos 2015-10-27 05:11 EDT
Created attachment 1086756 [details]
anaconda-tb
Comment 3 Marian Csontos 2015-10-27 05:12 EDT
Created attachment 1086757 [details]
kickstart
Comment 4 Marian Csontos 2015-10-27 05:13 EDT
Created attachment 1086758 [details]
Tarball with logs
Comment 5 Marian Csontos 2015-10-27 05:25:57 EDT
This happens only with non interactive KS install.

Using GUI installer proper warning was issued and it is possible to recover by using different location for repos.
Comment 6 Alexander Todorov 2016-02-25 04:09:50 EST
I can reliably reproduce this on one particular system with fully automated kickstart install.
Comment 8 Alexander Todorov 2016-02-25 04:11:51 EST
*** Bug 1289259 has been marked as a duplicate of this bug. ***
Comment 9 Alexander Todorov 2016-02-25 04:12:34 EST
*** Bug 1294700 has been marked as a duplicate of this bug. ***
Comment 10 Alexander Todorov 2016-02-25 04:12:58 EST
*** Bug 1304480 has been marked as a duplicate of this bug. ***
Comment 13 Jiri Konecny 2016-03-01 07:51:28 EST
I also did general patch for this problem yesterday.

PR: https://github.com/rhinstaller/anaconda/pull/530
Comment 14 Jiri Konecny 2016-03-03 05:08:58 EST
*** Bug 1314095 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2016-03-09 11:32:04 EST
anaconda-24.13.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d85d9ad927
Comment 16 Fedora Update System 2016-03-09 20:55:00 EST
anaconda-24.13.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d85d9ad927
Comment 17 Fedora Update System 2016-03-26 14:14:40 EDT
anaconda-24.13.1-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.