Bug 1289353 - Make alua prioritizer able to exclusively use the preferred path, if available
Make alua prioritizer able to exclusively use the preferred path, if available
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ben Marzinski
Zhang Yi
:
Depends On:
Blocks: 1299652 1305997 1364188
  Show dependency treegraph
 
Reported: 2015-12-07 17:33 EST by Ben Marzinski
Modified: 2016-08-04 12:22 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Add an optional argument to the alua prioritizer, "exclusive_pref_bit". If this argument is added, and a path has the TPGS pref bit set. Multipath will make a pathgroup using only that path, and assign it the highest priority Reason: Some users want to use the TPGS pref bit to specify a single path that multipath should prefer to use. This was previously done. However, and change to how the prioritizers worked make this no longer happen. This option restores the ability for those who need it. Result: Users can now either allow the preferred path to be in a path group with other paths that are equally optimized (the default) or in a path group by itself (by adding the exclusive_pref_bit argument)
Story Points: ---
Clone Of:
: 1299652 1305997 (view as bug list)
Environment:
Last Closed: 2016-05-10 16:13:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Marzinski 2015-12-07 17:33:59 EST
Description of problem:
In RHEL-6.6, if the preferred path bit was set for a path, multipath would create a pathgroup containing only that path. Starting in RHEL-6.7, multipath would also include other paths at the same optimization level.  However, some customers want to use the preferred path to tell multipath that if that path is avilable it should only use that path, not just to make sure that path is in the active pathgroup.

Version-Release number of selected component (if applicable):
device-mapper-multipath-0.4.9-87.el6

How reproducible:
always

Steps to Reproduce:
1. Set ALUA tpg PREF bit on an active/optimized port group in a multipathed array, with other port groups also in the active/optimized state
2. start multipath on the paths from the array
3.

Actual results:
All of the active/optimized paths will be in the multipath's active pathgroup

Expected results:
Only the preferred path will be in multipath's active pathgroup

Additional info:
Comment 1 Ben Marzinski 2016-01-13 14:04:19 EST
The multipath alua prioritizer now allows a an option, "exclusive_pref_bit"

If you use

    prio "alua exclusive_pref_bit"

in your device configuration, multipath will create a pathgroup that only contains the path with the pref bit set, and will give that pathgroup the highest priority.
Comment 11 errata-xmlrpc 2016-05-10 16:13:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0777.html

Note You need to log in before you can comment on or make changes to this bug.