Bug 1299652 - Make alua prioritizer able to exclusively use the preferred path, if available
Summary: Make alua prioritizer able to exclusively use the preferred path, if available
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-multipath   
(Show other bugs)
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Ben Marzinski
QA Contact: Zhang Yi
Milan Navratil
URL:
Whiteboard:
Keywords:
Depends On: 1289353 1305997
Blocks: 1313485 1295577 1364188
TreeView+ depends on / blocked
 
Reported: 2016-01-18 22:01 UTC by Ben Marzinski
Modified: 2016-11-04 08:17 UTC (History)
14 users (show)

Fixed In Version: device-mapper-multipath-0.4.9-87.el7
Doc Type: Release Note
Doc Text:
The "exclusive_pref_bit" optional argument has been added to the *multipath* ALUA prioritizer If the "exclusive_pref_bit" argument is added to the *multipath* Asymmetric Logical Unit Access (ALUA) prioritizer, and a path has the Target Port Group Support (TPGS) `pref` bit set, *multipath* makes a path group using only that path and assigns the highest priority to the path. Users can now either allow the preferred path to be in a path group with other paths that are equally optimized, which is the default option, or in a path group by itself by adding the "exclusive_pref_bit" argument.
Story Points: ---
Clone Of: 1289353
: 1364188 (view as bug list)
Environment:
Last Closed: 2016-11-04 08:17:04 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2536 normal SHIPPED_LIVE device-mapper-multipath bug fix and enhancement update 2016-11-03 14:18:10 UTC

Comment 1 Ben Marzinski 2016-02-26 22:56:11 UTC
The multipath alua prioritizer now allows a an option, "exclusive_pref_bit"

If you use

    prio "alua exclusive_pref_bit"

in your device configuration, multipath will create a pathgroup that only contains the path with the pref bit set, and will give that pathgroup the highest priority.

Comment 2 Ben Marzinski 2016-03-17 21:23:14 UTC
Oops. Comment 1 used the RHEL6 syntax.  In RHEL7, you would add

prio_args "exclusive_pref_bit"

to your device configuration. This is only used if you have

prio "alua"

set as well.

Comment 12 errata-xmlrpc 2016-11-04 08:17:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2536.html


Note You need to log in before you can comment on or make changes to this bug.