Bug 1289436 - Can't set week start to Monday
Can't set week start to Monday
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mate-panel (Show other bugs)
23
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Wolfgang Ulbrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 01:20 EST by Sergei S. Rublёv
Modified: 2016-09-15 08:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-10 05:27:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergei S. Rublёv 2015-12-08 01:20:30 EST
I can't set week start to Monday in Fedora MATE. There is no such selector in the GUI. But previously in earlier Fedoras there were some ways, now I can't anymore.

Generally, I cannot set system language to Russian. There is system-config-language in menu. I suggest when I set language to Russian, the system changes also week start day. System-config-language is set to Russian, but system language doesn't change. I heard at linuxforum.ru this is a common problem. People there said I should execute "localectl set-locale LANG=ru_RU.utf8". This worked for 1 time in Fedora 22, but then I got to 23 and this doesn't work any more.

Generally I don't care much about system language, but I care about Monday weekstart in calendar in mate-panel. In other DE's it is usually set with "country standards" or there's special selector dedicated to that (in Cinnamon e. g.). In Fedora MATE I can't find this. System-config-date doesn't have that. There are also "Clock Preferences" — can't find. But these "Clock Preferences" have the parameter "Show week numbers in calendar" — I don't see any week numbers in calendar in mate-panel. "Time settings" also shows calendar, but still no week numbers, and no week start.

So, how do I set week start to Monday in Fedora MATE?
Comment 1 Wolfgang Ulbrich 2015-12-08 06:37:49 EST
There was never a setting for changing week start in clock applet.
System-config-language sets the general language for the system and system needs a restart for applying the setting.
You can also change the language in lightdm greeter, note for some reassons you need 2 logouts/login for appying the setting with using lightdm.

I recall that there was a guy on irc channel who had the same problem with the weekstart with swiss-french locale.
In the end it was a problem with the locale file itself.
I quess the week starts on sunday, right?
I need to call the guy to ask him how it gets fixed.
Comment 2 Sergei S. Rublёv 2015-12-08 09:06:55 EST
Thank you for the info! Yes, week currently starts on Sunday.
Comment 3 Wolfgang Ulbrich 2015-12-08 13:37:47 EST
See https://bugzilla.redhat.com/show_bug.cgi?id=1204521
It looks like that those 2 lines are missing in your locale file.
first_weekday 2
first_workday 2

Under /usr/share/i18n/locales i found 8 locale files for rusia and 3 of them dont have this lines.
ce_RU + tt_RU + tt_RU@igtelif
Do you use them?
Try to add this 2 parameter just before the line: END LC_TIME
Than execute
localedef -v -c -i fr_CH -f UTF-8 fr_CH.UTF-8  (adjust for your locale)

and restart mate-session.
Comment 4 Sergei S. Rublёv 2015-12-09 20:00:16 EST
Thank you again very much! My solution was:

Open /usr/share/i18n/locales/en_US

Change "first_weekday	1" to "first_weekday	2" (was already present)

Then:
sudo localedef -v -c -i en_US -f UTF-8 en_US.UTF-8

Then re-login
Comment 5 Wolfgang Ulbrich 2015-12-10 05:27:34 EST
Ahh, i missread you post, you wanted to change the english locale.
Comment 6 Sergei S. Rublёv 2016-09-15 08:04:43 EDT
I am trying to correct this now in Fedora 24 and found /usr/share/i18n/locales/ directory is empty! Where did the locale files go? I again want to set weekstart to Moday instead of Sunday in en_US

Note You need to log in before you can comment on or make changes to this bug.