Bug 1289447 - Sharding - Iozone on sharded volume fails on NFS
Sharding - Iozone on sharded volume fails on NFS
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: sharding (Show other bugs)
mainline
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Krutika Dhananjay
bugs@gluster.org
: Triaged
Depends On:
Blocks: 1289570
  Show dependency treegraph
 
Reported: 2015-12-08 02:15 EST by Krutika Dhananjay
Modified: 2016-06-16 09:49 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289570 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:49:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2015-12-08 02:15:26 EST
Description of problem:

Same as "Summary".

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2015-12-08 02:34:06 EST
REVIEW: http://review.gluster.org/12907 (features/shard: Do not update inode-ctx size (again) after xattrop) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Vijay Bellur 2015-12-08 16:46:45 EST
COMMIT: http://review.gluster.org/12907 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 5fa88405ba1aba2312902255282fc4f6625d18ed
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Dec 8 12:47:42 2015 +0530

    features/shard: Do not update inode-ctx size (again) after xattrop
    
    This is to fix race between parallel writevs that could mess up
    the file size value in inode ctx.
    
    Thanks to Pranith for helping with RCA'ing the issue.
    
    Change-Id: Ief94e0b3bcd87a8e2391fb39af1b99d020abd764
    BUG: 1289447
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/12907
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Niels de Vos 2016-06-16 09:49:19 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.