This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1289570 - Sharding - Iozone on sharded volume fails on NFS
Sharding - Iozone on sharded volume fails on NFS
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: sharding (Show other bugs)
3.7.6
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Krutika Dhananjay
bugs@gluster.org
: Triaged
Depends On: 1289447
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 07:57 EST by Krutika Dhananjay
Modified: 2016-04-19 03:50 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1289447
Environment:
Last Closed: 2016-04-19 03:50:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2015-12-08 07:57:03 EST
+++ This bug was initially created as a clone of Bug #1289447 +++

Description of problem:

Same as "Summary".

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2015-12-08 02:34:06 EST ---

REVIEW: http://review.gluster.org/12907 (features/shard: Do not update inode-ctx size (again) after xattrop) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 1 Vijay Bellur 2015-12-08 07:58:57 EST
REVIEW: http://review.gluster.org/12911 (features/shard: Do not update inode-ctx size (again) after xattrop) posted (#1) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Vijay Bellur 2015-12-09 01:16:03 EST
COMMIT: http://review.gluster.org/12911 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 2142614f385352903d0cdb67657f2e639b79f72c
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Dec 8 12:47:42 2015 +0530

    features/shard: Do not update inode-ctx size (again) after xattrop
    
            Backport of: http://review.gluster.org/#/c/12907/
    
    This is to fix race between parallel writevs that could mess up
    the file size value in inode ctx.
    
    Thanks to Pranith for helping with RCA'ing the issue.
    
    Change-Id: I8e26d92568434bc6c60b0c23089532bf3bdac509
    BUG: 1289570
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/12911
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 3 Kaushal 2016-04-19 03:50:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.