Bug 1289557 - [RFE] add output of "multipathd show config" in sosreport
[RFE] add output of "multipathd show config" in sosreport
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sos (Show other bugs)
7.2
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Pavel Moravec
BaseOS QE - Apps
: FutureFeature
: 1341098 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 07:30 EST by George Angelopoulos
Modified: 2016-11-11 03:09 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
The multipath plug-in has been updated in the sos package. The plug-in newly captures "multipathd show config" command output. This allows users to get information about the currently loaded multipath configuration.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-11 03:09:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Angelopoulos 2015-12-08 07:30:58 EST
This is a request for enhancement.

Description of problem:
When investigating multipath issues, it is not possible to view the currently loaded configuration for multipath. We have to infer it by considering the defaults for the specific package version and the user-defined options.


Version-Release number of selected component (if applicable):


How reproducible: consistently


Steps to Reproduce:
1. run "sosreport"

Actual results:
1. No output of "multipathd show config" in the generated archive.

Expected results:
1. In the extracted sosreport archive, there's a beautiful "sos_commands/multipath/multipathd_show_config" file. \o/


Additional info:
Upstream commit: https://github.com/sosreport/sos/commit/85e9152ea6a95c144f6a50e47bba12e7fab65ef2
GitHub Issue: https://github.com/sosreport/sos/issues/697
suggested by cbuissar
Comment 1 Pavel Moravec 2015-12-08 08:35:28 EST
Setting flags to ? and devel_ack to + due to upstream fix.
Comment 2 Mike McCune 2016-03-28 19:20:28 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 3 Bryn M. Reeves 2016-04-05 09:07:46 EDT
commit 85e9152ea6a95c144f6a50e47bba12e7fab65ef2
Author: Bryn M. Reeves <bmr@redhat.com>
Date:   Tue Dec 8 11:51:11 2015 +0000

    [multipath] collect output of 'multipathd show config'
    
    Resolves: #697.
    
    Signed-off-by: Bryn M. Reeves <bmr@redhat.com>
Comment 4 Pavel Moravec 2016-11-11 03:09:09 EST
This has been fixed in upstream sos 3.3 we rebased to by [1] in RHEL7.3. Errata [2] should resolve this bug.

Please test [2] and in case it does not address the reported problem properly, reopen this BZ.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1293044
[2] https://rhn.redhat.com/errata/RHBA-2016-2380.html
Comment 5 Pavel Moravec 2016-11-11 03:09:51 EST
*** Bug 1341098 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.