Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1341098 - [RFE] add output of "multipathd show config" in sosreport
Summary: [RFE] add output of "multipathd show config" in sosreport
Keywords:
Status: CLOSED DUPLICATE of bug 1289557
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sos
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Pavel Moravec
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On: 1293044
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-31 09:22 UTC by Martin Frodl
Modified: 2016-11-11 08:09 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1289558
Environment:
Last Closed: 2016-11-11 08:09:51 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Martin Frodl 2016-05-31 09:22:04 UTC
+++ This bug was initially created as a clone of Bug #1289558 +++

This is a request for enhancement.

Description of problem:
When investigating multipath issues, it is not possible to view the currently loaded configuration for multipath. We have to infer it by considering the defaults for the specific package version and the user-defined options.

Version-Release number of selected component (if applicable):
sos-3.2-35.el7.noarch

How reproducible:
consistently

Steps to Reproduce:
1. run "sosreport"

Actual results:
1. No output of "multipathd show config" in the generated archive.

Expected results:
1. In the extracted sosreport archive, there's a beautiful "sos_commands/multipath/multipathd_show_config" file. \o/

Additional info:
Upstream commit: https://github.com/sosreport/sos/commit/85e9152ea6a95c144f6a50e47bba12e7fab65ef2
GitHub Issue: https://github.com/sosreport/sos/issues/697
suggested by cbuissar

Comment 2 Pavel Moravec 2016-05-31 09:58:51 UTC
The fix committed to upstream will appear in 7.3 due to sos rebase in https://bugzilla.redhat.com/show_bug.cgi?id=1293044 .

Comment 3 Pavel Moravec 2016-11-11 08:09:51 UTC
DUP of bz1289557, just closed as fixed in RHEL7.3

*** This bug has been marked as a duplicate of bug 1289557 ***


Note You need to log in before you can comment on or make changes to this bug.