Bug 1289558 - [RFE] add output of "multipathd show config" in sosreport
[RFE] add output of "multipathd show config" in sosreport
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sos (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Shane Bradley
Martin Frodl
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 07:32 EST by George Angelopoulos
Modified: 2016-05-10 17:08 EDT (History)
10 users (show)

See Also:
Fixed In Version: sos-3.2-38.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1341098 (view as bug list)
Environment:
Last Closed: 2016-05-10 17:08:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Angelopoulos 2015-12-08 07:32:22 EST
This is a request for enhancement.

Description of problem:
When investigating multipath issues, it is not possible to view the currently loaded configuration for multipath. We have to infer it by considering the defaults for the specific package version and the user-defined options.


Version-Release number of selected component (if applicable):


How reproducible: consistently


Steps to Reproduce:
1. run "sosreport"

Actual results:
1. No output of "multipathd show config" in the generated archive.

Expected results:
1. In the extracted sosreport archive, there's a beautiful "sos_commands/multipath/multipathd_show_config" file. \o/


Additional info:
Upstream commit: https://github.com/sosreport/sos/commit/85e9152ea6a95c144f6a50e47bba12e7fab65ef2
GitHub Issue: https://github.com/sosreport/sos/issues/697
suggested by cbuissar
Comment 7 errata-xmlrpc 2016-05-10 17:08:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0819.html

Note You need to log in before you can comment on or make changes to this bug.