Bug 1289571 - providing oscap content name more than 255 chars throws error
providing oscap content name more than 255 chars throws error
Status: CLOSED NEXTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: SCAP Plugin (Show other bugs)
6.1.5
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Ondřej Pražák
http://projects.theforeman.org/issues...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 08:12 EST by Kedar Bidarkar
Modified: 2017-08-01 15:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 15:57:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 12882 None None None 2016-04-22 11:35 EDT

  None (edit)
Description Kedar Bidarkar 2015-12-08 08:12:40 EST
Description of problem:

providing oscap content name more than 255 chars throws error

PGError: ERROR: value too long for type character varying(255) : INSERT INTO "scaptimony_scap_contents" ("created_at", "digest", "original_filename", "scap_file", "title", "updated_at") VALUES ($1, $2, $3, $4, $5, $6) RETURNING "id"

Version-Release number of selected component (if applicable):

Satellite 6.1.4 GA

How reproducible:
Always

Steps to Reproduce:
1. create a new oscap_content and provide name more than 255 chars
2. 
3.

Actual results:
providing oscap content name more than 255 chars throws error

Expected results:
providing oscap content name more than 255 chars, should throw "name too long" error instead of DB error.

Additional info:
Comment 2 Bryan Kearney 2015-12-18 15:41:06 EST
Created redmine issue http://projects.theforeman.org/issues/12882 from this bug
Comment 3 Bryan Kearney 2015-12-21 11:40:59 EST
Is this the same as https://bugzilla.redhat.com/show_bug.cgi?id=1289571
Comment 4 Kedar Bidarkar 2016-01-13 04:48:50 EST
Looks like the bug in comment3 is pointing to this bug itself. May be you wanted to refer another bug.
Comment 5 Bryan Kearney 2016-02-02 06:14:54 EST
*** Bug 1293296 has been marked as a duplicate of this bug. ***
Comment 7 Bryan Kearney 2016-06-22 10:11:02 EDT
Upstream bug assigned to oprazak@redhat.com
Comment 8 Bryan Kearney 2016-06-22 10:11:05 EDT
Upstream bug assigned to oprazak@redhat.com
Comment 9 Bryan Kearney 2016-06-22 16:11:00 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/12882 has been closed
Comment 11 Bryan Kearney 2017-08-01 15:57:55 EDT
The fix to this bug will be delivered with release 6.3 of Satellite.

Note You need to log in before you can comment on or make changes to this bug.