Bug 1293296 - oscap policy name can be created more than 255 chars
oscap policy name can be created more than 255 chars
Status: CLOSED NEXTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: SCAP Plugin (Show other bugs)
6.1.5
Unspecified Unspecified
low Severity low (vote)
: Unspecified
: --
Assigned To: Marek Hulan
http://projects.theforeman.org/issues...
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 06:08 EST by Kedar Bidarkar
Modified: 2017-08-01 15:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 15:57:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 12900 None None None 2016-04-22 13:01 EDT

  None (edit)
Description Kedar Bidarkar 2015-12-21 06:08:57 EST
Description of problem:

Currently oscap policy name field accepts more than 255 chars and this needs to be checked while adding it in the field itself.

We face the below issues while clicking the submit button.

PGError: ERROR: value too long for type character varying(255) : INSERT INTO "scaptimony_policies" ("created_at", "cron_line", "day_of_month", "description", "name", "period", "scap_content_id", "scap_content_profile_id", "updated_at", "weekday") VALUES ($1, $2, $3, $4, $5, $6, $7, $8, $9, $10) RETURNING "id"


2015-12-21 16:26:14 [I] Processing by ScaptimonyPoliciesController#create as HTML
2015-12-21 16:26:14 [I]   Parameters: {"utf8"=>"✓", "authenticity_token"=>"9d+EQhT93SuywO2kHu1ubkWx7ArbU6qbGE6DFMeCrz0=", "policy"=>{"current_step"=>"", "name"=>"wJNLfPbexTKCGSGdqWjfOsYbetvPhzTBrptteHCIUcjYaacfDzyDnfVmOdsZQWcfIWDfXoLuJLtwEPHjCpSoIzSsYnhBqDcovaLsfHYQtHVQEeNORkhydwKaTqcivVPaCaZQFoRZPWJZCetgRphracvkyMUjKRayVaCrvaLaBBbjOjeWlknHUFpRsLHQkvbuvsZGxWqEMfmwfNIoknRoDaWRFPpoCMtEitUdRUAlyEGGeswFlDsUhlWCFKaZHSizOplYRcVDdxtBmkPjdNrwFEWVdMgnPWWOaiOvMsUhMbXc", "description"=>"", "scap_content_id"=>"14", "scap_content_profile_id"=>"114", "period"=>"weekly", "weekday"=>"sunday", "day_of_month"=>"", "cron_line"=>"", "location_ids"=>[""], "organization_ids"=>["", "1"], "hostgroup_ids"=>[""]}, "commit"=>"Submit"}

2015-12-21 16:26:14 [W] Operation FAILED: PGError: ERROR:  value too long for type character varying(255)
: INSERT INTO "scaptimony_policies" ("created_at", "cron_line", "day_of_month", "description", "name", "period", "scap_content_id", "scap_content_profile_id", "updated_at", "weekday") VALUES ($1, $2, $3, $4, $5, $6, $7, $8, $9, $10) RETURNING "id"
2015-12-21 16:26:14 [I]   Rendered common/500.html.erb within layouts/application (19.8ms)
2015-12-21 16:26:14 [I]   Rendered layouts/base.html.erb (3.6ms)
2015-12-21 16:26:14 [I] Completed 500 Internal Server Error in 126ms (Views: 33.6ms | ActiveRecord: 17.4ms)
2015-12-21 16:29:14 [I] Processing by HostsController#externalNodes as YML




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Try creating a oscap - policy with more than 255 chars
2. Provide all the entries and click submit.
3.

Actual results:
oscap policy_name field accepts more than 255 chars

Expected results:
oscap policy_name field should detect more than 255 chars and report to the user that the length is too long.

Additional info:
Comment 2 Bryan Kearney 2015-12-21 11:32:55 EST
Created redmine issue http://projects.theforeman.org/issues/12900 from this bug
Comment 3 Bryan Kearney 2016-02-02 06:14:54 EST

*** This bug has been marked as a duplicate of bug 1289571 ***
Comment 5 Oleksandr Shtaier 2016-05-15 09:32:56 EDT
It is not a duplicate of 1289571 since here we are talking about OSCAP policy and in 1289571 about OSCAP content. These are two different entities
Comment 6 Bryan Kearney 2016-07-26 11:25:24 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 7 Bryan Kearney 2016-07-26 11:37:38 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 9 Bryan Kearney 2016-09-12 08:11:41 EDT
Upstream bug assigned to mhulan@redhat.com
Comment 10 Bryan Kearney 2016-09-12 08:11:44 EDT
Upstream bug assigned to mhulan@redhat.com
Comment 11 Bryan Kearney 2016-09-13 06:11:35 EDT
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/12900 has been resolved.
Comment 16 Bryan Kearney 2017-08-01 15:57:45 EDT
The fix to this bug will be delivered with release 6.3 of Satellite.

Note You need to log in before you can comment on or make changes to this bug.