This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1289578 - [Tier]: Failed to open "demotequeryfile-master-tier-dht" errors logged on the node having only cold bricks
[Tier]: Failed to open "demotequeryfile-master-tier-dht" errors logged on the...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Joseph Elwin Fernandes
bugs@gluster.org
: ZStream
Depends On:
Blocks: 1260783 1290048
  Show dependency treegraph
 
Reported: 2015-12-08 08:32 EST by Joseph Elwin Fernandes
Modified: 2016-06-16 09:49 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1289071
: 1290048 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:49:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-08 08:34:37 EST
REVIEW: http://review.gluster.org/12912 (tier : Spawn promotion or demotion thread depending on local bricks) posted (#1) for review on master by Joseph Fernandes
Comment 2 Vijay Bellur 2015-12-08 12:42:32 EST
REVIEW: http://review.gluster.org/12912 (tier : Spawn promotion or demotion thread depending on local bricks) posted (#2) for review on master by Joseph Fernandes
Comment 3 Vijay Bellur 2015-12-08 16:51:54 EST
REVIEW: http://review.gluster.org/12912 (tier : Spawn promotion or demotion thread depending on local bricks) posted (#3) for review on master by Vijay Bellur (vbellur@redhat.com)
Comment 4 Vijay Bellur 2015-12-09 08:34:18 EST
COMMIT: http://review.gluster.org/12912 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit bcc4c12360c1a63bae5b787e519a35c32b48ae83
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Tue Dec 8 18:56:31 2015 +0530

    tier : Spawn promotion or demotion thread depending on local bricks
    
    Spawn Promotion or Demotion depending if there are any Cold or Hot
    bricks present localy.
    IF the local HOT brick list is empty dont spawn demote thread.
    IF the local COLD brick list is empty dont spawn promote thread.
    
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    
    Change-Id: I524730e59414dd156c78ec0bd7a3629212697e6e
    BUG: 1289578
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    Reviewed-on: http://review.gluster.org/12912
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 5 Niels de Vos 2016-06-16 09:49:19 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.