Bug 1290048 - [Tier]: Failed to open "demotequeryfile-master-tier-dht" errors logged on the node having only cold bricks
[Tier]: Failed to open "demotequeryfile-master-tier-dht" errors logged on the...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
: ZStream
Depends On: 1289578
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-12-09 09:56 EST by Joseph Elwin Fernandes
Modified: 2016-04-19 03:50 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1289578
Environment:
Last Closed: 2016-04-19 03:50:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-09 09:56:36 EST
REVIEW: http://review.gluster.org/12928 (tier : Spawn promotion or demotion thread depending on local bricks) posted (#1) for review on release-3.7 by Joseph Fernandes
Comment 2 Vijay Bellur 2015-12-09 12:30:48 EST
COMMIT: http://review.gluster.org/12928 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit b7bdcc39b057ef6057778bd0ab8f36376fd76db0
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Tue Dec 8 18:56:31 2015 +0530

    tier : Spawn promotion or demotion thread depending on local bricks
    
    Spawn Promotion or Demotion depending if there are any Cold or Hot
    bricks present localy.
    IF the local HOT brick list is empty dont spawn demote thread.
    IF the local COLD brick list is empty dont spawn promote thread.
    
    Backport of http://review.gluster.org/12912
    
    > Change-Id: I524730e59414dd156c78ec0bd7a3629212697e6e
    > BUG: 1289578
    > Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    > Reviewed-on: http://review.gluster.org/12912
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: N Balachandran <nbalacha@redhat.com>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    > Tested-by: Dan Lambright <dlambrig@redhat.com>
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    
    Change-Id: Ic3113934051c7a751ae56508e00d098d010f4c0e
    BUG: 1290048
    Reviewed-on: http://review.gluster.org/12928
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2016-04-19 03:50:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.