Bug 1289766 - [DOCS] Pre deployment for EFK stack needs info on cert origin and use.
[DOCS] Pre deployment for EFK stack needs info on cert origin and use.
Status: CLOSED CANTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Vikram Goyal
Vikram Goyal
Vikram Goyal
:
: 1288402 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 17:37 EST by Ryan Howe
Modified: 2017-12-27 09:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-27 09:36:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Howe 2015-12-08 17:37:05 EST
Document URL: https://docs.openshift.com/enterprise/3.1/install_config/aggregate_logging.html#pre-deployment-configuration

Section Number and Name: pre-deployment-configuration

Describe the issue: 

1. In step 2 we need information on where the certs and keys are coming from, or how the user can create these. 

2. In step 4 it has you adding a service account to the the SCC that is different from the one that is created.

system:serviceaccount:logging:logging-deployer

vs.

system:serviceaccount:logging:aggregated-logging-fluentd
Comment 1 Ryan Howe 2015-12-08 17:40:17 EST
Ignore #2  regarding the use of different service accounts as the service account is created during the deployer pod.
Comment 2 Kenjiro Nakayama 2015-12-08 19:16:05 EST
*** Bug 1288402 has been marked as a duplicate of this bug. ***
Comment 4 Ryan Howe 2015-12-09 13:31:32 EST
Also: 

In step 2 only the kibana.crt and key should be used, If other keys and json file are added to secret the kibana pod will not work when deployed. 


$ oc secrets new logging-deployer \
   kibana.crt=/path/to/cert kibana.key=/path/to/key
Comment 5 Vikram Goyal 2017-12-27 09:36:15 EST
It looks like major changes were made to this section since this bug was created. Some of the steps referenced are no longer there.

I am going to close this bug as cantfix, but if changes still need to be made, please reopen.

Note You need to log in before you can comment on or make changes to this bug.