Bug 1289769 - Unable to boot Nova instances after updating from 7.1 -> 7.2
Unable to boot Nova instances after updating from 7.1 -> 7.2
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity high
: y2
: 7.0 (Kilo)
Assigned To: Emilien Macchi
Marius Cornea
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 17:38 EST by Marius Cornea
Modified: 2015-12-21 11:54 EST (History)
7 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.6-91.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 11:54:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs and neutron.conf (1.03 MB, application/x-gzip)
2015-12-08 17:38 EST, Marius Cornea
no flags Details

  None (edit)
Description Marius Cornea 2015-12-08 17:38:38 EST
Created attachment 1103736 [details]
logs and neutron.conf

Description of problem:
After a 7.1 -> 7.2 update booting a nova instance fails. I applied the workaround mentioned in BZ#1289097

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.6-87.el7ost.noarch with patch in
https://bugzilla.redhat.com/show_bug.cgi?id=1289097#c3

How reproducible:
100%

Steps to Reproduce:
1. Deploy 7.1 overcloud 
2. Run some workload on the overcloud
3. Update the undercloud and overcloud to 7.2 by following the procedure
4. Spawn new instances on the overcloud 

Actual results:
vm02   | ERROR  | spawning   | NOSTATE 

Expected results:
vm02   | ACTIVE | -          | Running 

Additional info:
The neutron server.log shows the following error:
ERROR neutron.notifiers.nova [-] Failed to notify nova on events: [{'status': 'completed', 'tag': u'6b3b6fdb-35af-4f98-aae9-7792673ef630', 'name': 'network-vif-unplugged', 'server_uuid': u'3b2936f6-2e47-4fa3-a
77c-13f95ca68518'}]


Attaching the neutron server.log and neutron.conf on one of the controllers and the nova-compute.log.
Comment 3 Emilien Macchi 2015-12-08 19:06:49 EST
Marius, in https://bugzilla.redhat.com/show_bug.cgi?id=1289097 provided a new build: openstack-tripleo-heat-templates-0.8.6-89.el7ost

Could you test this build and not the workaround?

I've looked at the patch added in the build [1] and I think it will fix your bug.
If not, please let us know.

[1] https://code.engineering.redhat.com/gerrit/#/c/63313
Comment 6 Emilien Macchi 2015-12-08 20:33:39 EST
I managed to boot VMs by modifying neutron.conf

Before (impossible to boot VM)
project_name=services
username=nova
password=9e3f75a07f314d8d87811fcc2da4ad86682ef12c
project_domain_id=default
tenant_name=service
user_domain_id=default
auth_url=http://192.0.2.6:35357/v2.0

After (VM now boot)
# Timeout value for http requests
# timeout =
project_name=service <---- change
username=nova
password=9e3f75a07f314d8d87811fcc2da4ad86682ef12c
project_domain_id=default
tenant_name=service
user_domain_id=default
auth_url=http://192.0.2.6:35357 <---- change

I'm working on a patch in tripleo-heat-templates right now.
Comment 11 errata-xmlrpc 2015-12-21 11:54:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2651

Note You need to log in before you can comment on or make changes to this bug.