Bug 1289781 - Fix Angular form rendering issues visible on slower machines and add focus to the first element in the form
Fix Angular form rendering issues visible on slower machines and add focus to...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 5.6.0
Assigned To: Aparna Karve
Taras Lehinevych
: ZStream
Depends On:
Blocks: 1290016
  Show dependency treegraph
 
Reported: 2015-12-08 18:54 EST by Aparna Karve
Modified: 2016-08-02 21:33 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1290016 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:18:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Red "Required" boxes that are briefly visible for existing records (68.23 KB, image/png)
2015-12-08 18:54 EST, Aparna Karve
no flags Details

  None (edit)
Description Aparna Karve 2015-12-08 18:54:49 EST
Created attachment 1103743 [details]
Red "Required" boxes that are briefly visible for existing records

Description of problem: An angularized form (like cloud provider) sometimes loads itself prematurely even before the actual initialization of angular has occurred. This issue is more pronounced on slower machines. Attached screenshot might give a better picture of the problem.


Version-Release number of selected component (if applicable):5.5.z


How reproducible: Sometimes. Visible on slower machines


Steps to Reproduce:
1. Open an existing Cloud Provider, Host or Provider foreman in the edit mode
2.
3.

Actual results:Red border boxes with "Required" are shown for a split second and then the values are populated.




Expected results: Clean loading of the form. Red boxes should not be visible for existing records


Additional info:
Comment 2 Aparna Karve 2015-12-09 09:29:17 EST
This is already fixed in upstream.
Comment 3 Taras Lehinevych 2016-04-28 05:24:40 EDT
Verified in 5.6.0.4-beta2.3
Comment 5 errata-xmlrpc 2016-06-29 11:18:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.