Bug 1290016 - Fix Angular form rendering issues visible on slower machines and add focus to the first element in the form
Fix Angular form rendering issues visible on slower machines and add focus to...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 5.5.2
Assigned To: Aparna Karve
Alex Newman
: ZStream
Depends On: 1289781
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 09:05 EST by John Prause
Modified: 2016-02-10 10:27 EST (History)
9 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1289781
Environment:
Last Closed: 2016-02-10 10:27:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 CFME Bot 2015-12-09 12:08:19 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=d08b487215a9f0623ade8e2a6fcb6d9ded3aec5f

commit d08b487215a9f0623ade8e2a6fcb6d9ded3aec5f
Author:     Aparna Karve <akarve@redhat.com>
AuthorDate: Wed Nov 25 11:19:08 2015 -0800
Commit:     Aparna Karve <akarve@redhat.com>
CommitDate: Wed Dec 9 06:32:13 2015 -0800

    Fix angular form startup render issue for Foreman form
    Also added focus on first element in the form
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290016

 app/views/provider_foreman/_form.html.haml | 106 +++++++++++++++--------------
 1 file changed, 56 insertions(+), 50 deletions(-)
Comment 2 CFME Bot 2015-12-09 12:08:24 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=15f1da172673ba0bf6bb642ecd781e3186100053

commit 15f1da172673ba0bf6bb642ecd781e3186100053
Merge: 6cb4e71 d08b487
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Wed Dec 9 12:06:55 2015 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Wed Dec 9 12:06:55 2015 -0500

    Merge branch 'fix_angular_form_startup_render' into '5.5.z'
    
    Fixed the angular rendering issue at startup that is sometimes visible
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290016
    
    Clean cherry-pick.
    Upstream PR - https://github.com/ManageIQ/manageiq/pull/5543
    
    The auto-focus directive will now be deployed to set the display 'on' on the form once all the json data is fetched. The directive will then set focus on the first field in the form.
    
    This is being done in order to resolve a known problem with angular forms where just before the form loads, for a brief second or so, the fields are marked red since the form json data is still being fetched from the server. This issue is quite pronounced on slower machines.
    
    See merge request !596

 .../ems_common/ems_common_form_controller.js       |   4 -
 app/assets/javascripts/directives/autofocus.js     |   4 +-
 app/views/host/_form.html.haml                     | 198 +++++++++++----------
 app/views/provider_foreman/_form.html.haml         | 106 +++++------
 .../views/ems_common/angular/_form.html.haml       |  19 +-
 5 files changed, 169 insertions(+), 162 deletions(-)
Comment 4 errata-xmlrpc 2016-02-10 10:27:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.