Bug 128979 - autofs does not see changes in NIS automounter map
autofs does not see changes in NIS automounter map
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
: 134792 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2004-08-02 12:39 EDT by Jeremy Sanders
Modified: 2014-01-21 17:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-05 16:10:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jeremy Sanders 2004-08-02 12:39:21 EDT
Description of problem:
We use NIS to provide automounter maps for autofs. Our NIS server is
hosted on a RH7.3 system.

When we modified an automounter map on the NIS server, and did a make,
autofs on the FC2 machines did not see the updated automounter map. If
we did "ypcat mapname" on the FC2 machines, we saw the updated lines,
but autofs didn't automatically get the changes. The FC1 and RedHat
7.3 systems automatically saw the NIS map update. We had to do a "kill
-HUP" on the autofs daemons to get the updates on FC2. This seems to
be always reproducable.

This is quite a serious problem, as the FC2 machines saw the original
autofs mountpoints until we did a kill -HUP.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Configure autofs to listen to a NIS map.
2. Change the automounter map and type make.
Actual results:

Expected results:

Additional info:

The auto.master map looks like this:
[root@xserv1 src]# cat auto.master
/home auto.home -rsize=8192,wsize=8192,intr
/data auto.data -rsize=8192,wsize=8192,intr
/data1 auto.data1 -rsize=8192,wsize=8192,intr
/scratch auto.scratch -rsize=8192,wsize=8192,intr
Comment 1 Jeffrey Moyer 2004-08-02 12:52:15 EDT
This is a known problem.  A proposed patch is undergoing testing
currently and will be available in the coming weeks.
Comment 2 Jeffrey Moyer 2004-10-14 20:11:17 EDT
*** Bug 134792 has been marked as a duplicate of this bug. ***
Comment 3 Paul Raines 2004-10-14 22:01:31 EDT
In my case, bug 1374792, even doing the 'kill -HUP' did not get 
autofs to see the changes.  But probably the underlying bug is the 
Comment 4 Seth Vidal 2005-01-10 11:26:20 EST
Any status change on this known bug?
Comment 5 Seth Vidal 2005-01-10 11:29:05 EST
Also - on the systems I have where this bug has shown up we've had to do:
kill -HUP $pidof_automount
/etc/init.d/autofs reload

then it fixed it.
Comment 6 Jeremy Sanders 2005-01-10 11:41:30 EST
Unfortunately we don't have any FC3 machines to test for the fix. Maybe we/you
could try doing an update on the autofs rpm? :-)
Comment 7 Jeffrey Moyer 2005-01-10 11:48:22 EST
There has been no fix released for this issue just yet.  When an rpm containing
the fix is available, I will update the bug.
Comment 8 Jeffrey Moyer 2005-04-05 16:10:29 EDT
A fix for this now appears in FC3 and Rawhide.  Please re-open this bug if you
find the problem has not been resolved.


Note You need to log in before you can comment on or make changes to this bug.