Bug 1289840 - Sharding: Remove dependency on performance.strict-write-ordering
Sharding: Remove dependency on performance.strict-write-ordering
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: sharding (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krutika Dhananjay
bugs@gluster.org
: Triaged
Depends On:
Blocks: 1290655
  Show dependency treegraph
 
Reported: 2015-12-09 01:37 EST by Krutika Dhananjay
Modified: 2016-06-16 09:49 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1290655 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:49:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2015-12-09 01:37:13 EST
Description of problem:
Same as "Summary". With http://review.gluster.org/#/c/12907/, iozone runs fine even without strict-write-ordering enabled on distributed replicated volumes.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2015-12-09 01:38:36 EST
REVIEW: http://review.gluster.org/12915 (tests, shard: Remove dependency on strict-write-ordering) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Vijay Bellur 2015-12-10 23:40:53 EST
COMMIT: http://review.gluster.org/12915 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 3a01c1b36724ad4c9148540b56a26b3c1799c583
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Dec 8 14:31:30 2015 +0530

    tests, shard: Remove dependency on strict-write-ordering
    
    Change-Id: I00171a77bdefb1c2e7e4610cb0ade5679bdb761f
    BUG: 1289840
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/12915
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 3 Niels de Vos 2016-06-16 09:49:41 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.