Bug 1290655 - Sharding: Remove dependency on performance.strict-write-ordering
Sharding: Remove dependency on performance.strict-write-ordering
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: sharding (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krutika Dhananjay
bugs@gluster.org
: Triaged
Depends On: 1289840
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 23:45 EST by Krutika Dhananjay
Modified: 2016-04-19 03:50 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1289840
Environment:
Last Closed: 2016-04-19 03:50:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2015-12-10 23:45:36 EST
+++ This bug was initially created as a clone of Bug #1289840 +++

Description of problem:
Same as "Summary". With http://review.gluster.org/#/c/12907/, iozone runs fine even without strict-write-ordering enabled on distributed replicated volumes.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2015-12-09 01:38:36 EST ---

REVIEW: http://review.gluster.org/12915 (tests, shard: Remove dependency on strict-write-ordering) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-10 23:40:53 EST ---

COMMIT: http://review.gluster.org/12915 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 3a01c1b36724ad4c9148540b56a26b3c1799c583
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Dec 8 14:31:30 2015 +0530

    tests, shard: Remove dependency on strict-write-ordering
    
    Change-Id: I00171a77bdefb1c2e7e4610cb0ade5679bdb761f
    BUG: 1289840
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/12915
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 1 Vijay Bellur 2015-12-10 23:49:21 EST
REVIEW: http://review.gluster.org/12946 (tests, shard: Remove dependency on strict-write-ordering) posted (#1) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Vijay Bellur 2015-12-15 03:34:35 EST
COMMIT: http://review.gluster.org/12946 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 37c8cf7a51919600ea793774a5b443dcf8566e94
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Dec 8 14:31:30 2015 +0530

    tests, shard: Remove dependency on strict-write-ordering
    
            Backport of: http://review.gluster.org/#/c/12915/
    
    Change-Id: I11968c32e57f73589e442fa13391f922fa4bbf2a
    BUG: 1290655
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/12946
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 3 Kaushal 2016-04-19 03:50:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.