Bug 1289849 - FreeRadius should start after ldap, ipa and krb5kdc
FreeRadius should start after ldap, ipa and krb5kdc
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: freeradius (Show other bugs)
7.1
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: Nikolai Kondrashov
Jaroslav Aster
:
: 1344408 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 02:14 EST by wibrown@redhat.com
Modified: 2017-08-01 16:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 16:36:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wibrown@redhat.com 2015-12-09 02:14:54 EST
Description of problem:
If freeradius is installed on the same machine as an ipa master, 389-ds master, or kdc, radius will often start before the other services are ready to handle queries. As a result, this causes freeradius to be fail to connect to ldap / krb and will not start or will fail to server authentication events.

The radiusd.service file should be altered to contain the following "After" line:

[Unit]
Description=FreeRADIUS high performance RADIUS server.
After=syslog.target network.target ipa.service dirsrv.target krb5kdc.service

This does not affect the radius start up on systems that don't have any of these three services installed.
Comment 4 Nikolai Kondrashov 2016-06-09 14:22:27 EDT
*** Bug 1344408 has been marked as a duplicate of this bug. ***
Comment 8 errata-xmlrpc 2017-08-01 16:36:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1954

Note You need to log in before you can comment on or make changes to this bug.