Bug 1289859 - Symlinks Rename fails in Symlink not exists in Slave
Symlinks Rename fails in Symlink not exists in Slave
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Aravinda VK
:
Depends On:
Blocks: 1292697
  Show dependency treegraph
 
Reported: 2015-12-09 03:27 EST by Aravinda VK
Modified: 2016-06-16 09:49 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1292697 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:49:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aravinda VK 2015-12-09 03:27:06 EST
Description of problem:
If Symlink creation failed in Slave and then it is renamed in Master. Geo-rep session goes to Faulty while renaming Symlink.

How reproducible:


Steps to Reproduce:
1. Create a file in Master(say f1)
2. Create symlink s1 in Master(say s1. ln -s f1 s1) and wait till it syncs to Slave. 
3. Wait for some time and add data to f1 and wait till it syncs to slave.(Just to make sure that rename will get recorded in different Changelog file)
4. Delete symlink in Slave
5. Rename symlink in Master
6. Check the status of Geo-replication.

Actual results:
Geo-rep session goes to Faulty

Expected results:
Should not go to Faulty

Additional info:
Comment 1 Vijay Bellur 2015-12-09 03:27:40 EST
REVIEW: http://review.gluster.org/12917 (geo-rep: Symlink Rename issue) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 2 Vijay Bellur 2015-12-10 04:25:59 EST
REVIEW: http://review.gluster.org/12917 (geo-rep: Symlink Rename issue) posted (#3) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 3 Vijay Bellur 2015-12-18 00:46:42 EST
COMMIT: http://review.gluster.org/12917 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit 3151194fad1aed3ab340b53aeeb4e8d131538d12
Author: Aravinda VK <avishwan@redhat.com>
Date:   Wed Dec 9 13:46:17 2015 +0530

    geo-rep: Symlink Rename issue
    
    If ENTRY creation failed for symlink in Slave and symlink
    renamed in Master. If Source not exists to Rename in Slave
    Geo-rep interprets as Create of Target file. Geo-rep sends blob
    of regular file to create symlink instead of sending blob of
    symlink.
    
    With this patch, Geo-rep identifies symlink and sends respective
    blob.
    
    BUG: 1289859
    Change-Id: If9351974d1945141a1d3abb838b7d0de7591e48e
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/12917
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-by: Milind Changire <mchangir@redhat.com>
    Tested-by: Milind Changire <mchangir@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 4 Niels de Vos 2016-06-16 09:49:41 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.