Bug 1292697 - Symlinks Rename fails in Symlink not exists in Slave
Summary: Symlinks Rename fails in Symlink not exists in Slave
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: 3.7.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On: 1289859
Blocks: glusterfs-3.7.7
TreeView+ depends on / blocked
 
Reported: 2015-12-18 06:11 UTC by Aravinda VK
Modified: 2016-04-19 07:51 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Clone Of: 1289859
Environment:
Last Closed: 2016-02-15 06:31:06 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2015-12-18 06:11:37 UTC
+++ This bug was initially created as a clone of Bug #1289859 +++

Description of problem:
If Symlink creation failed in Slave and then it is renamed in Master. Geo-rep session goes to Faulty while renaming Symlink.

How reproducible:


Steps to Reproduce:
1. Create a file in Master(say f1)
2. Create symlink s1 in Master(say s1. ln -s f1 s1) and wait till it syncs to Slave. 
3. Wait for some time and add data to f1 and wait till it syncs to slave.(Just to make sure that rename will get recorded in different Changelog file)
4. Delete symlink in Slave
5. Rename symlink in Master
6. Check the status of Geo-replication.

Actual results:
Geo-rep session goes to Faulty

Expected results:
Should not go to Faulty

Additional info:

--- Additional comment from Vijay Bellur on 2015-12-09 03:27:40 EST ---

REVIEW: http://review.gluster.org/12917 (geo-rep: Symlink Rename issue) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-10 04:25:59 EST ---

REVIEW: http://review.gluster.org/12917 (geo-rep: Symlink Rename issue) posted (#3) for review on master by Aravinda VK (avishwan@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-18 00:46:42 EST ---

COMMIT: http://review.gluster.org/12917 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit 3151194fad1aed3ab340b53aeeb4e8d131538d12
Author: Aravinda VK <avishwan@redhat.com>
Date:   Wed Dec 9 13:46:17 2015 +0530

    geo-rep: Symlink Rename issue
    
    If ENTRY creation failed for symlink in Slave and symlink
    renamed in Master. If Source not exists to Rename in Slave
    Geo-rep interprets as Create of Target file. Geo-rep sends blob
    of regular file to create symlink instead of sending blob of
    symlink.
    
    With this patch, Geo-rep identifies symlink and sends respective
    blob.
    
    BUG: 1289859
    Change-Id: If9351974d1945141a1d3abb838b7d0de7591e48e
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/12917
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-by: Milind Changire <mchangir@redhat.com>
    Tested-by: Milind Changire <mchangir@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>

Comment 1 Vijay Bellur 2015-12-18 06:12:22 UTC
REVIEW: http://review.gluster.org/12998 (geo-rep: Symlink Rename issue) posted (#1) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)

Comment 2 Vijay Bellur 2016-01-04 06:35:41 UTC
COMMIT: http://review.gluster.org/12998 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit a69ea2e635eb2ba64f53e3d280b345cb2a65ad13
Author: Aravinda VK <avishwan@redhat.com>
Date:   Wed Dec 9 13:46:17 2015 +0530

    geo-rep: Symlink Rename issue
    
    If ENTRY creation failed for symlink in Slave and symlink
    renamed in Master. If Source not exists to Rename in Slave
    Geo-rep interprets as Create of Target file. Geo-rep sends blob
    of regular file to create symlink instead of sending blob of
    symlink.
    
    With this patch, Geo-rep identifies symlink and sends respective
    blob.
    
    BUG: 1292697
    Change-Id: If9351974d1945141a1d3abb838b7d0de7591e48e
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/12917
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-by: Milind Changire <mchangir@redhat.com>
    Tested-by: Milind Changire <mchangir@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
     (cherry picked from commit 3151194fad1aed3ab340b53aeeb4e8d131538d12)
    Reviewed-on: http://review.gluster.org/12998
    Reviewed-by: Venky Shankar <vshankar@redhat.com>

Comment 3 Kaushal 2016-04-19 07:51:26 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.