Bug 128986 - (IT_44347) upgraded (3.4) satellite sends duplicate errata alert messages
upgraded (3.4) satellite sends duplicate errata alert messages
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
All Linux
high Severity high
: ---
: ---
Assigned To: Mihai Ibanescu
Fanny Augustin
:
Depends On:
Blocks: rhn360sat
  Show dependency treegraph
 
Reported: 2004-08-02 14:49 EDT by Alexandre Oliva
Modified: 2007-07-31 10:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-23 15:25:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-08-02 14:49:59 EDT
The Satellite server is sending out duplicate errata alert e-mail
messages after each nightly satellite-sync.  Hundreds of duplicate
e-mails are being sent each day.

I am running the latest version of satellite, 3.4, and the database
schema.

Upgraded from V2.0

schema version was 2.5-91.1

This is with mostly old errata that have already been applied to
target systems.
Comment 4 Chip Turner 2004-08-04 17:33:44 EDT
1) We need the output of 'satellite-debug' mailed to us (by output I
  mean /tmp/satellite-debug.tar.bz2, not stdout)
                                                                     
                                                            
2) We need sample emails, including full headers, of the duplicates
                                                                     
                                                            
3) We need /var/log/maillog from the satellite during a time that
   duplicate emails were sent
Comment 5 Chip Turner 2004-08-04 17:38:41 EDT
also, please send the output of this sql.  First, run sqlplus:

sqlplus rhnsat/rhnsat@rhnsat

then, once in sql plus, execute these three queries and send the
results to us:

SELECT COUNT(*) FROM RHNEMAILADDRESS;
SELECT COUNT(*) FROM WEB_CONTACT;
SELECT COUNT(DISTINCT EMAIL) FROM WEB_USER_PERSONAL_INFO;

thanks
Comment 7 Alexandre Oliva 2004-08-05 08:39:49 EDT
SQL output:

SQL> SELECT COUNT(*) FROM RHNEMAILADDRESS;
 
  COUNT(*)
----------
       101
 
SQL> SELECT COUNT(*) FROM WEB_CONTACT;
 
  COUNT(*)
----------
       101
 
SQL> SELECT COUNT(DISTINCT EMAIL) FROM WEB_USER_PERSONAL_INFO;
 
COUNT(DISTINCTEMAIL)
--------------------
                 101

I'll upload the other requested files as private.
Comment 10 Chip Turner 2004-08-06 07:22:16 EDT
okay at this point we've eliminated the theories we have internally on
the issue and are trying a second attempt to reproduce as well as
analyzing the code in question for flaws.  we will let you know ASAP
when we have further information or need more data from your satellite.
Comment 11 Alexandre Oliva 2004-08-09 13:36:39 EDT
Customer says:

I changed my satellite sync cron job to run a single command:

satellite-sync

I was using a separate command line satellite-sync -c channel  for
each channel.

This change appears to have eliminated the problems associated with
this ticket  including redundant e-mails, bogus errata scheduling,
syncs taking a very long time, taskomatic running for hours on end,
and channel packages not showing for some errata.

I made the cron change for the weekend.  The saturday and sunday syncs
errored out with the same error, but the monday one ran through
completely and all looks good.  I will monitor the sync for the next
several days.
Comment 12 Alexandre Oliva 2004-08-24 09:21:52 EDT
Ping.  Do we have an ETA for a fix for the, erhm, spam :-) when
syncing individual channels?
Comment 13 Todd Warner 2004-08-24 10:03:12 EDT
Assigning to the appropriate person and linking to rhn360sat
s/cturner/misa
Comment 14 Mihai Ibanescu 2004-10-06 22:44:57 EDT
I believe Cliff mentioned something about auto-errata.
This may be fixed in 360 with the refactoring of satellite-sync, but
since we don't have a reproducer it's hard to tell. Moving to ON_DEV,
QA may have a better chance to reproduce this. Todd, please coordinate
with cperry if he has more details about this.
Comment 15 Todd Warner 2004-10-21 12:17:54 EDT
QA push. {ON_DEV,QA_READY} --> ON_QA
Comment 16 Fanny Augustin 2004-11-20 13:22:54 EST
There are too many comments and I cannot figure out what is the real
problem/issue.  Could you please provide a test plan or ways to
reproduce the error to make sure it has been fixed? Thanks!
Comment 17 Mihai Ibanescu 2004-11-23 11:19:13 EST
We never managed to reproduce this in our environments.
Comment 18 Fanny Augustin 2004-11-23 15:25:36 EST
I haven't seen any duplicate erratas...  Closing this bug as we never
were able to reproduce it in our evn.

Note You need to log in before you can comment on or make changes to this bug.