Bug 1289972 - After resizing virt-viewer window bigger than screen size, window gets resized back to screen size, and content scaled down
After resizing virt-viewer window bigger than screen size, window gets resize...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Virt Viewer Maint
Virtualization Bugs
:
Depends On: 1205804 1242509
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 07:50 EST by Fabiano Fidêncio
Modified: 2016-05-10 17:19 EDT (History)
19 users (show)

See Also:
Fixed In Version: virt-viewer-2.0-8.el6
Doc Type: Bug Fix
Doc Text:
When viewing a remote SPICE session in windowed mode and resizing the viewer window be wider than the virtual screen, the viewer window was automatically resized to fit the screen width, and the resolution of the remote screen was scaled down. This unintentional behavior has been corrected, and in the described scenario, the both the viewer window and the resolution of its contents stay unchanged
Story Points: ---
Clone Of: 1242509
Environment:
Last Closed: 2016-05-10 17:19:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 xiaodwan 2015-12-14 03:37:01 EST
I can reproduce it with virt-viewer-2.0-7.el6.x86_64 with below steps:

1. Prepare a rhel6 spice guest, make the resolution can adjust automatically after changing the remote-viewer window size.
2. Drag the window to the left of the screen, make sure the left part of remote-viewer window can not be displayed.
3. Drag bottom right corner of the remote-viewer window to the very bottom right corner of the screen.

Actual Result:
Window width is set back.

Try it with virt-viewer-2.0-8.el6.x86_64 and the window width stay same.

So the bug is fixed and move it to verified.
Comment 4 errata-xmlrpc 2016-05-10 17:19:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0832.html

Note You need to log in before you can comment on or make changes to this bug.