Bug 129000 - rawhide installation fails on installing filesystem-2.2.4-1 - selinux errors in log
Summary: rawhide installation fails on installing filesystem-2.2.4-1 - selinux errors ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-08-02 20:53 UTC by Jason Vas Dias
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 19:27:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason Vas Dias 2004-08-02 20:53:59 UTC
Description of problem:

I tried to install rawhide-20040802 with SELinux 'Active'.
anaconda aborts with the error dialog 
"There was an error installing filesystem-2.4.2-1 ... Reboot."

In terminal 3, it says: 
'*moving(1) to step install packages
*setting file_context_path to
/etc/selinux/targeted/contexts/files/file_context" 

and in terminal 1 it says:
"/etc/selinux/targeted/context/files/file_contexts: invalid context
system_u:object_r:httpd_user_content_t on line 613
" - the same message is repeated for line 716.

Version-Release number of selected component (if applicable):

rawhide-20040802
selinux-policy-strict-1.15.11-1.noarch.rpm
selinux-policy-strict-sources-1.15.11-1.noarch.rpm
selinux-policy-targeted-1.15.11-1.noarch.rpm
selinux-policy-targeted-sources-1.15.11-1.noarch.rpm


How reproducible:

100%

Steps to Reproduce:
1. Install rawhide-200408 with selinux active
2.
3.
  
Actual results:
   Install aborts as above
 
Expected results:
   Install should complete.

Additional info:

Spoke to notting about this, and he suggested I raise this bug.

Comment 1 Jason Vas Dias 2004-08-02 21:10:43 UTC
I tried again choosing the 'Disable SELinux' option; this time 
I got the same anaconda error, (There was an error installing
fileutils-2.2.4) .
This time, I went to the shell (CTRL+ALT+F2) and did:
$ cat /mnt/sysimage/root/install.log
...
error: unpacking of archive failed on file /lib/modules: cpio: lsetfilecon



Comment 2 Jason Vas Dias 2004-08-04 21:28:49 UTC
*** Bug 114145 has been marked as a duplicate of this bug. ***

Comment 3 Jason Vas Dias 2004-08-04 21:35:30 UTC
114145 is NOT a duplicate of this bug - that was a typo.


Note You need to log in before you can comment on or make changes to this bug.