Bug 114145 - 3C905B-TX ethernet card not working with DHCP, only Static IP
Summary: 3C905B-TX ethernet card not working with DHCP, only Static IP
Status: CLOSED DUPLICATE of bug 129096
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-23 02:22 UTC by mike foley
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mike foley 2004-01-23 02:22:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040113

Description of problem:
When using Fedora Core 1 and a 3Com 3C905B-TX ethernet card, the card
refuses to get a DHCP address. Change the IP address to Static and
it comes right up.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Fedora on a system with a 3C905B-tx
2.Select DHCP
3.Start network, no DHCP address given.
4. Change to Static
5. Restart network, bingo, you're online.
    

Additional info:

Comment 1 Need Real Name 2004-02-04 14:52:32 UTC
I've seen this same behaviour with a 3c905-TX. 

Comment 2 Mark Baertschy 2004-03-13 01:15:00 UTC
I have the same problem with a VIA Rhine VT6102
on an Athlon 64 laptop. Static IP works fine.
When I try to bring up with DHCP I get the following
error message.

>> ifup eth0:1
Determining IP information for eth0:1...SIOCSIFFLAGS: Cannot assign
requested address
SCIOCSIFFLAGS: Cannot assign requested address
 failed.

The ifcfg-eth0:1 script was generated by redhat-config-network


Comment 3 Martti Huttunen 2004-03-22 15:24:19 UTC
Actually, in all my machines it matters not if it's DHCP.
You'd always get a "PCI bus master error" which actually suggested a 
bad media setting in the driver FAQ. Funny, since it's on autodetect 
and the switch seems perfectly happy with 100M setup. Worked on 
RedHat 7.3 and 9 flawlessly.

Moving the service network to 00 priority (started before anything 
else) solved all my problems. I tried with 2 kernels, one I've been 
using for 6(?) months (2.4.20) and Fedora (2.4.22-something). No 
difference. So, suspects are: microcode update, kudzu and iptables. 
Can't confirm which. In the other machine it was enough to postpone 
the microcode update, in the other one that wasn't enough.

Machines:
Athlon 1800 + ASUS A7V333, 3Com 905B-TX, Adaptec 2940, Hauppauge 
BT848 card, CMI PCI Audio, Radeon 7500, static network config

Duron 800 + Abit (VIA62C686B), 3Com 905B-TX, ES1370 AudioPCI, Roland 
SCC-1, 3dfx Voodoo 3, network using DHCP


Comment 4 Colin Charles 2004-04-04 04:43:22 UTC
Have tried this on Fedora Core 1, fresh install from a CD, and using
the 3COM 3C905B-TX and the card gets a DHCP IP address with no
problems whatsoever. This happens during boot-up, and there is no
network problem.

Hardware is a Cel 1.7GHz, with a Gigabyte GA-81845GV (having the Intel
845GV chipset). Looks like NOTABUG.

Comment 5 Daniel Walsh 2004-06-23 19:47:23 UTC
Probably a kernel driver problem.  Arjan ideas?

Comment 6 Jason Vas Dias 2004-08-04 21:28:34 UTC
The problem is using an pseudo-interface like 'eth0:1' - 
DHCP cannot be used to configure such interfaces - they
have the same ethernet address as the real card. 
Using a real interface (eth0) should be no problem.
See bug 129000 .

*** This bug has been marked as a duplicate of 129000 ***

Comment 7 Jason Vas Dias 2004-08-04 21:30:27 UTC
The problem is using an pseudo-interface like 'eth0:1' - 
DHCP cannot be used to configure such interfaces - they
have the same ethernet address as the real card. 
Using a real interface (eth0) should be no problem.
See bug 129096 .

yes, it is a duplicate of 129096, not 129000 - sorry!


*** This bug has been marked as a duplicate of 129096 ***

*** This bug has been marked as a duplicate of 129096 ***

Comment 8 Jason Vas Dias 2004-08-04 21:37:36 UTC

*** This bug has been marked as a duplicate of 129096 ***

Comment 9 Red Hat Bugzilla 2006-02-21 19:00:53 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.