Bug 1290042 - overcloud systems are not registered to RHSM during deployment
overcloud systems are not registered to RHSM during deployment
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
All Linux
urgent Severity high
: ---
: 10.0 (Newton)
Assigned To: James Slagle
Shai Revivo
: Reopened, Triaged
Depends On:
Blocks: 1290226
  Show dependency treegraph
 
Reported: 2015-12-09 09:44 EST by Dan Yocum
Modified: 2016-10-04 14:51 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The environment file needed to register overcloud nodes is usually included automatically when any of the RHEL registration parameters are specified on the cli, however in some circumstances, it can be overridden unintentionally. Consequence: The overcloud nodes are not registered to either the portal or satellite even though the parameters were specifed on the command line. Fix: To make sure the nodes get registered, pass the needed environment file explicitly on the cli: -e ~/templates/extraconfig/pre_deploy/rhel-registration/rhel-registration-resource-registry.yaml (where ~/templates is the path to the templates used in the deployment). This environment file should be passed after overcloud-resource-registry-puppet.yaml on the cli. Result: Overcloud nodes are registered to the portal or satellite, whichever is in use.
Story Points: ---
Clone Of:
: 1290226 (view as bug list)
Environment:
Last Closed: 2016-10-04 14:49:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pre-and-post-hooks-environment.yaml (307 bytes, text/plain)
2015-12-09 11:02 EST, Dan Yocum
no flags Details
storage-environment.yaml (1.92 KB, text/plain)
2015-12-09 11:02 EST, Dan Yocum
no flags Details
network-environment.yaml (4.18 KB, text/plain)
2015-12-09 11:03 EST, Dan Yocum
no flags Details
ceph-wipe-environment.yaml (209 bytes, text/plain)
2015-12-09 11:03 EST, Dan Yocum
no flags Details
overcloud-resource-registry-puppet.yaml (5.44 KB, text/plain)
2015-12-09 11:03 EST, Dan Yocum
no flags Details

  None (edit)
Description Dan Yocum 2015-12-09 09:44:31 EST
Description of problem:

During deployment of the overcloud, the nodes are NOT registered to RHSM.

Version-Release number of selected component (if applicable):

7.1

How reproducible:

Every

Steps to Reproduce:
1. Deploy using this command:

openstack overcloud deploy \
-t 120 \
--templates ~/templates \
-e ~/templates/overcloud-resource-registry-puppet.yaml \
-e ~/templates/ceph-wipe-environment.yaml \
-e ~/templates/network-environment.yaml \
-e ~/templates/storage-environment.yaml \
-e ~/templates/pre-and-post-hooks-environment.yaml \
--control-scale 3 \
--compute-scale 13 \
--ceph-storage-scale 4 \
--control-flavor control \
--compute-flavor compute \
--ceph-storage-flavor ceph-storage \
--ntp-server 10.5.26.10 \
--neutron-network-type vxlan \
--neutron-tunnel-types vxlan \
--libvirt-type kvm \
--rhel-reg \
--reg-method portal \
--reg-org <my org key> \
--reg-activation-key <my activation key name> \
--reg-force 


Actual results:

[root@overcloud-controller-0 ~]# subscription-manager status
+-------------------------------------------+
   System Status Details
+-------------------------------------------+
Overall Status: Unknown


Expected results:
[root@overcloud-controller-0 heat-admin]# subscription-manager status
+-------------------------------------------+
   System Status Details
+-------------------------------------------+
Overall Status: Current



Additional info:
Comment 2 Mike Burns 2015-12-09 09:54:46 EST
There are options for the CLI to register to satellite or CDN.

See the rhel-reg options here:  https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/appe-Deployment_Parameters.html
Comment 3 Mike Burns 2015-12-09 10:06:16 EST
Sorry, misread the bug.  Reopening...
Comment 4 Dan Yocum 2015-12-09 11:02 EST
Created attachment 1103966 [details]
pre-and-post-hooks-environment.yaml
Comment 5 Dan Yocum 2015-12-09 11:02 EST
Created attachment 1103967 [details]
storage-environment.yaml
Comment 6 Dan Yocum 2015-12-09 11:03 EST
Created attachment 1103968 [details]
network-environment.yaml
Comment 7 Dan Yocum 2015-12-09 11:03 EST
Created attachment 1103969 [details]
ceph-wipe-environment.yaml
Comment 8 Dan Yocum 2015-12-09 11:03 EST
Created attachment 1103970 [details]
overcloud-resource-registry-puppet.yaml
Comment 9 James Slagle 2015-12-09 11:48:54 EST
can you retry the deployment command and pass this as the last -e argument:

-e ~/templates/extraconfig/pre_deploy/rhel-registration/rhel-registration-resource-registry.yaml
Comment 10 James Slagle 2015-12-09 15:30:27 EST
(In reply to James Slagle from comment #9)
> can you retry the deployment command and pass this as the last -e argument:
> 
> -e
> ~/templates/extraconfig/pre_deploy/rhel-registration/rhel-registration-
> resource-registry.yaml

i confirmed with dan that this did work.

the issue here is with passing overcloud-resource-registry-puppet.yaml via -e, as that is going to override any environment setting done by the client. In the case of rhel registration, the client automatically sets NodeExtraConfig to rhel-registration.yaml, but when you include overcloud-resource-registry-puppet.yaml on the cli, then that gets overwritten.
Comment 11 Dan Yocum 2015-12-09 18:10:26 EST
Additionally, rhel_reg_repos is not set in templates/extraconfig/pre_deploy/rhel-registration/environment-rhel-registration.yaml.  Should this be set to the default set of repos that customers get with an RHOS subscription?
Comment 12 Dan Yocum 2015-12-10 15:39:39 EST
AFAICT, these repos should be enabled by default:

rhel-7-server-rpms
rhel-7-server-rh-common-rpms
rhel-7-server-openstack-7.0-rpms
rhel-7-server-rhceph-1.3-calamari-rpms
rhel-7-server-rhceph-1.3-mon-rpms
rhel-7-server-rhceph-1.3-osd-rpms
rhel-7-server-rhceph-1.3-tools-rpms

I think they should get added to extraconfig/pre_deploy/rhel-registration/environment-rhel-registration.yaml
Comment 13 Mike Burns 2015-12-11 07:23:33 EST
(In reply to Dan Yocum from comment #12)
> AFAICT, these repos should be enabled by default:
> 
> rhel-7-server-rpms
> rhel-7-server-rh-common-rpms
> rhel-7-server-openstack-7.0-rpms

Yes, might also need rhel-7-server-openstack-7.0-director-rpms, but not sure

> rhel-7-server-rhceph-1.3-calamari-rpms

No -- we don't include calamari

> rhel-7-server-rhceph-1.3-mon-rpms
> rhel-7-server-rhceph-1.3-osd-rpms
> rhel-7-server-rhceph-1.3-tools-rpms

Optional.  Some customers won't have ceph entitlements, so won't have these repos to enable.  Maybe enable them if available, but not if not available.

> 
> I think they should get added to
> extraconfig/pre_deploy/rhel-registration/environment-rhel-registration.yaml
Comment 15 Mike Burns 2016-04-07 17:00:12 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 17 Jaromir Coufal 2016-10-04 14:49:10 EDT
This seems to be resolved.

Note You need to log in before you can comment on or make changes to this bug.