This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 129008 - Installer crashed after I tried to upgrade my FC2 system to FC3-test1
Installer crashed after I tried to upgrade my FC2 system to FC3-test1
Status: CLOSED DUPLICATE of bug 127713
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-02 18:27 EDT by Eddie K.
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eddie K. 2004-08-02 18:27:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040707 Firefox/0.9.2

Description of problem:
I just tried to update my Fedora Core 2 system to Fedora Core 3 test1,
and selected "Fedora Core 2 (/dev/hda2)" from the action screen
(upgrade or clean install). I kept upgrade selected. After that, I got
a screen saying about the kickstart, etc. I clicked Next, and then got
an unhandled exception.

Here is the traceback data:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1057, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/process_gui.py", line 242, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 772, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 169, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 237, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 737, in doPreInstall
    os.mkdir(instPath + "/selinux")
OSError: [Errno 17] File exists: '/mnt/sysimage/selinux'

- Eddie

Version-Release number of selected component (if applicable):
Fedora Core 3 test1 (unknown version of anaconda)

How reproducible:
Always

Steps to Reproduce:
This requires a system with Fedora Core 2 installed.

1. Reboot into the FC3 test1 CD (disk 1)
2. Press enter for graphical installation
3. When you're at the "Welcome to Fedora Core" screen, click Next.
4. On the "Warning! This is pre-release software!", click Install anyway.
5. On the language screen, select "English (English)", the default
one, then click Next.
6. When you're on the Keyboard Configuration screen now, click "U.S.
English", then Next of course.
7. At the "Upgrade Examine" screen, click "Upgrade an existing
installation". The one which should be selected in the menu is "Fedora
Core 2 (/dev/hda2)", then Next.
8. On the "Upgrade Boot Loader Configuration" screen, keep "Update
boot loader configuration" selected. Then, click Next.
9. After the "Reading package information..." message, it will update
to "Finding packages to upgrade...". This is normal.
10. It will then say "Click next to begin upgrade of Fedora Core...",
with some more info. Click Next there.
11. On the "Required Install Media" message, click Continue.
12. It will then say "Transfering install image to hard drive...".
13. It will then crash.

Actual Results:  After I produced the steps, anaconda crashed again. I
did this 2 times with the same results. Extra information is in the
"Additional Information" field.

Expected Results:  Instead of crashing, FC3 should upgrade my system
and its packages. I know this is a test release - and is not
guaranteed to be stable.

I also did a media check, and the media got PASS, so it isn't the media.

Additional info:

I did not do a clean install because I do not want to lose any files
on the system - only tried an upgrade install.

System information:

Hard Drive - WDC 40GB Hard Drive
Processor - Intel Celeron 1.8GHz
Memory - 128MB
-- Current System Info --
Kernel version - 2.6.5 & 2.6.6
Version - Fedora Core 2
Comment 1 Jeremy Katz 2004-08-02 20:30:05 EDT

*** This bug has been marked as a duplicate of 127713 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:04:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.