Bug 1290125 - tests/basic/afr/arbiter-statfs.t fails most of the times on NetBSD
tests/basic/afr/arbiter-statfs.t fails most of the times on NetBSD
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ravishankar N
:
Depends On:
Blocks: 1290658
  Show dependency treegraph
 
Reported: 2015-12-09 12:19 EST by Michael Adam
Modified: 2016-06-16 09:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1290658 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:49:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Adam 2015-12-09 12:19:00 EST
Description of problem:

tests/basic/afr/arbiter-statfs.t fails on almost all NetBSD regression runs. This effectively prevents any patch from landing.

Proposal to add this to failing tests for the time being until it is resolved.
Comment 1 Vijay Bellur 2015-12-09 12:22:28 EST
REVIEW: http://review.gluster.org/12929 (tests: add basic/afr/arbiter-statfs.t to bad tests) posted (#1) for review on master by Michael Adam (obnox@samba.org)
Comment 2 Vijay Bellur 2015-12-10 02:21:49 EST
REVIEW: http://review.gluster.org/12936 (tests: Fix arbiter-statfs.t) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 3 Ravishankar N 2015-12-10 02:29:06 EST
Note the patch in comment #1 was abandoned in favour of http://review.gluster.org/#/c/12933/ which added many tests including arbiter-statfs.t to bad tests.

I'm using this same BZ to fix the test case (comment #2)
Comment 4 Vijay Bellur 2015-12-10 23:38:10 EST
COMMIT: http://review.gluster.org/12936 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit fc07e9c90db11bbbadf341d0720a874a8cd1fdc5
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Thu Dec 10 12:33:05 2015 +0530

    tests: Fix arbiter-statfs.t
    
    ..and remove it from bad tests list.
    
    Problem:
    https://build.gluster.org/job/rackspace-netbsd7-regression-triggered/12516/consoleFull
    
    ++ SETUP_LOOP /d/backends/brick1
    ++ '[' 1 '!=' 1 ']'
    ++ backend=/d/backends/brick1
    ++ case ${OSTYPE} in
    +++ awk -F: '/not in use/{print $1; exit}'
    +++ vnconfig -l
    vnconfig: VNDIOCGET: Bad file descriptor
    ++ vnd=
    ++ '[' x = x ']'
    ++ echo 'no more vnd'
    no more vnd
    ++ return 1
    
    Fix:
    TEST the return value of SETUP_LOOP.
    Also added EXIT_EARLY to the test case because there is no point in
    continuing the test when setting the bricks fail.
    
    Change-Id: I933611c41f93ac646f1170b62db656314c801ef1
    BUG: 1290125
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/12936
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 5 Raghavendra Talur 2016-03-10 02:40:52 EST
"tests" component is for tests framework only.
File a bug under test component if you find a bug in 
1. any of the *.rc files under tests/ 
2. run-tests.sh


For everything else, the bug should be filed on
1. component which is being tested by .t file if the .t file requires fix.
2. component which is causing a valid .t file to fail in regression.

I have used my best judgement here to move the bug to right component.
In case of ambiguity, I have placed the blame on the .t file component.

Please consider test bugs under the same backlog list that tracks other bugs in your component.
Comment 6 Niels de Vos 2016-06-16 09:49:41 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.