Bug 1290658 - tests/basic/afr/arbiter-statfs.t fails most of the times on NetBSD
tests/basic/afr/arbiter-statfs.t fails most of the times on NetBSD
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tests (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ravishankar N
:
Depends On: 1290125
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-11 00:07 EST by Ravishankar N
Modified: 2016-04-19 03:50 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1290125
Environment:
Last Closed: 2016-02-18 23:49:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravishankar N 2015-12-11 00:07:36 EST
+++ This bug was initially created as a clone of Bug #1290125 +++

Include fixes from http://review.gluster.org/#/c/12936/ to the 3.7 branch.
Comment 1 Vijay Bellur 2015-12-11 00:08:31 EST
REVIEW: http://review.gluster.org/12947 (Fix arbiter-statfs.t) posted (#1) for review on release-3.7 by Ravishankar N (ravishankar@redhat.com)
Comment 2 Vijay Bellur 2015-12-11 09:58:02 EST
REVIEW: http://review.gluster.org/12947 (Fix arbiter-statfs.t) posted (#2) for review on release-3.7 by Ravishankar N (ravishankar@redhat.com)
Comment 3 Vijay Bellur 2015-12-14 00:30:00 EST
COMMIT: http://review.gluster.org/12947 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 60912c650839a512e5b2f4a251100969f830996d
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Fri Dec 11 10:32:52 2015 +0530

    Fix arbiter-statfs.t
    
    ..and remove it from bad tests list.
    
    Backport of  http://review.gluster.org/#/c/12936/
    Problem:
    https://build.gluster.org/job/rackspace-netbsd7-regression-triggered/12516/consoleFull
    
    ++ SETUP_LOOP /d/backends/brick1
    ++ '[' 1 '!=' 1 ']'
    ++ backend=/d/backends/brick1
    ++ case ${OSTYPE} in
    +++ awk -F: '/not in use/{print $1; exit}'
    +++ vnconfig -l
    vnconfig: VNDIOCGET: Bad file descriptor
    ++ vnd=
    ++ '[' x = x ']'
    ++ echo 'no more vnd'
    no more vnd
    ++ return 1
    
    Fix:
    TEST the return value of SETUP_LOOP.
    Also added EXIT_EARLY to the test case because there is no point in
    continuing the test when setting the bricks fail.
    
    Change-Id: Idca269650385765a13be070186dc0b7eb2e5fda1
    BUG: 1290658
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/12947
    Reviewed-by: Michael Adam <obnox@samba.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 4 Ravishankar N 2016-02-18 23:49:29 EST
v3.7.7 contains a fix
Comment 5 Kaushal 2016-04-19 03:50:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.