Bug 129014 - Rebuilding of sed always fails
Rebuilding of sed always fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sed (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Ben Levenson
: EasyFix
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-02 20:05 EDT by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 4.1.2-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-08 07:25:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-08-02 20:05:15 EDT
Description of problem:
Rebuilding of sed will always fail, if the LANG environment 
variable isn't set to "C".

Version-Release number of selected component (if applicable):
sed-4.1.1-1

How reproducible:
Everytime, see below.

Steps to Reproduce:
1. export LANG=de_DE@euro
2. rpmbuild -ba sed.spec
3. Die with an error at "make check" (1 test is not passed)
   Well, the reason is, that there a sed output is compared,
   and a German and a English localized output aren't the
   same *hmpf*
  
Actual results:
Here's a diff from what is working for me:

--- snipp ---
--- sed.spec       2004-07-08 15:53:51.000000000 +0200
+++ sed.spec.rsc   2004-08-03 01:53:02.000000000 +0200
@@ -13,7 +13,7 @@
 Prefix: %{_prefix}
 Buildroot: %{_tmppath}/%{name}-root
 # Make sure glibc regex has all fixes we need
-BuildRequires: glibc >= 2.3.3-27, glibc-devel >= 2.3.3-27
+BuildRequires: glibc >= 2.3.2-27, glibc-devel >= 2.3.2-27

 %description
 The sed (Stream EDitor) editor is a stream or batch (non-interactive)
@@ -30,7 +30,7 @@
 make %{_smp_mflags}

 echo ====================TESTING=========================
-make check
+LANG=C make check
 echo ====================TESTING END=====================

 %install
@@ -60,6 +60,10 @@
 %{_mandir}/man*/*

 %changelog
+* Tue Aug 03 2004 Robert Scheck <redhat@linuxnetz.de>
+- changed requirement to glibc and glibc-devel
+- set LANG=C before make check to avoid problems
+
 * Thu Jul  8 2004 Jakub Jelinek <jakub@redhat.com> 4.1.1-1
 - update to 4.1.1

--- snapp ---

Expected results:
Use of the suggested changes ;-)

Additional info:
BTW, glibc 2.3.2-27 is even much enough, we don't need to require 
2.3.3-27, I tested rebuilding of sed against glibc of Red Hat 
Linux 9 - and it works fine. Maybe we should request the build 
arch i686 of glibc, because rebuilding against a i386 glibc will 
always fail. The strange requirement to a very recent glibc was 
(wrongly) introduced after bug #123043 and corrected by me soon, 
but still ignored - please fix this also :-(
Comment 1 Jakub Jelinek 2004-10-08 07:25:14 EDT
The LANG problem fixed differently (and submitted upstream)
in 4.1.2-4.
I'm not going to change the requirements on glibc (in fact I have
added even a Requires as well), as there were too many regex bugs
in earlier glibc releases.
For those glibcs you should probably remove --without-included-regex,
but the Fedora rpms really want to use it.
Comment 2 Robert Scheck 2004-10-09 10:26:55 EDT
I still have to comment your part about the glibc requirement: I'm 
able to rebuild 4.1.2-4 against a glibc (2.3.2-11.9) out of Red Hat 
Linux 9 for example (and everything is working without restrictions), 
so I think the requirement to such a new glibc is just foobar...if 
you think you need to require a actual glibc, 2.3.2-27 (not 2.3.3-27!) 
is absolutely more than enough...
Comment 3 Jakub Jelinek 2004-10-09 10:43:19 EDT
If you look at glibc ChangeLog between 2.3.2-27.* and 2.3.3-27, there
were more than 100 separate changes to regex code, many of them fixing
really serious bugs.

Note You need to log in before you can comment on or make changes to this bug.