Bug 1290170 - UI: Report Editor - After resetting changes on edit screen then trying to change tab throws an error
UI: Report Editor - After resetting changes on edit screen then trying to cha...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Harpreet Kataria
Niyaz Akhtar Ansari
:
Depends On:
Blocks: 1290440
  Show dependency treegraph
 
Reported: 2015-12-09 14:37 EST by Harpreet Kataria
Modified: 2016-06-29 11:18 EDT (History)
5 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1290440 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:18:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harpreet Kataria 2015-12-09 14:37:18 EST
Description of problem: After resetting changes on edit screen then trying to change tab throws an error


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Go Reports Explorer, Reports accordion
2. Click on a report to edit, or add a new report then try to edit the newly added report.
3. On Report edit screen make some changes and press Reset button, after that try to change any tab.

Actual results: No route matches {:action=>"_4", :controller=>"report", :id=>nil} [report/change_tab] 


Expected results: Should load contents of tab being clicked on


Additional info:
Session:	 Hash of Size 21862, Elements 34
=================================
[----] I, [2015-12-09T14:06:21.519546 #14908:fa5988]  INFO -- : Completed 200 OK in 464ms (Views: 0.5ms | ActiveRecord: 5.3ms)
[----] I, [2015-12-09T14:06:24.981427 #14908:fa5988]  INFO -- : Started POST "/report/change_tab?tab=_4" for 127.0.0.1 at 2015-12-09 14:06:24 -0500
[----] I, [2015-12-09T14:06:25.080708 #14908:fa5988]  INFO -- : Processing by ReportController#change_tab as JS
[----] I, [2015-12-09T14:06:25.080938 #14908:fa5988]  INFO -- :   Parameters: {"tab"=>"_4"}
[----] I, [2015-12-09T14:06:25.142455 #14908:fa5988]  INFO -- : Redirected to 
[----] F, [2015-12-09T14:06:25.142875 #14908:fa5988] FATAL -- : Error caught: [ActionController::UrlGenerationError] No route matches {:action=>"_4", :controller=>"report", :id=>nil}
/home/hkataria/.rvm/gems/ruby-2.2.2/gems/actionpack-4.2.5/lib/action_dispatch/journey/formatter.rb:46:in `generate'
/home/hkataria/.rvm/gems/ruby-2.2.2/gems/actionpack-4.2.5/lib/action_dispatch/routing/route_set.rb:721:in `generate'
/home/hkataria/.rvm/gems/ruby-2.2.2/gems/actionpack-4.2.5/lib/action_dispatch/routing/route_set.rb:752:in `generate'
/home/hkataria/.rvm/gems/ruby-2.2.2/gems/actionpack-4.2.5/lib/action_dispatch/routing/route_set.rb:799:in `url_for'
/home/hkataria/.rvm/gems/ruby-2.2.2/gems/actionpack-4.2.5/lib/action_dispatch/routing/url_for.rb:156:in `url_for'
/home/hkataria/.rvm/gems/ruby-2.2.2/gems/actionpack-4.2.5/lib/action_controller/metal/redirecting.rb:95:in `_compute_redirect_to_location'
/home/hkataria/.rvm/gems/ruby-2.2.2/gems/actionpack-4.2.5/lib/action_controller/metal/redirecting.rb:75:in `redirect_to'
/home/hkataria/.rvm/gems/ruby-2.2.2/gems/actionpack-4.2.5/lib/action_controller/metal/flash.rb:57:in `redirect_to'
/home/hkataria/.rvm/gems/ruby-2.2.2/gems/actionpack-4.2.5/lib/action_controller/metal/instrumentation.rb:64:in `block in redirect_to'
/home/hkataria/.rvm/gems/ruby-2.2.2/gems/activesupport-4.2.5/lib/active_support/notifications.rb:164:in `block in instrument'
/home/hkataria/.rvm/gems/ruby-2.2.2/gems/activesupport-4.2.5/lib/active_support/notifications/instrumenter.rb:20:in `instrument'
/home/hkataria/.rvm/gems/ruby-2.2.2/gems/activesupport-4.2.5/lib/active_support/notifications.rb:164:in `instrument'
/home/hkataria/.rvm/gems/ruby-2.2.2/gems/actionpack-4.2.5/lib/action_controller/metal/instrumentation.rb:63:in `redirect_to'
/home/hkataria/dev/manageiq/app/controllers/report_controller.rb:111:in `change_tab'
Comment 2 Harpreet Kataria 2015-12-11 12:58:26 EST
https://github.com/ManageIQ/manageiq/pull/5804
Comment 3 CFME Bot 2015-12-14 17:00:57 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/8ac9880d457acc56347ef07ae0da6586f8287b4c

commit 8ac9880d457acc56347ef07ae0da6586f8287b4c
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Fri Dec 11 12:20:14 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri Dec 11 12:56:34 2015 -0500

    Fixed issue in change tab after Reset is pressed in report editor
    
    - Fixed code to set prefix correctly for tab ids on tabs in Reports editor after Reset button is pressed
    - Added spec test to verify tab ids
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290440
    https://bugzilla.redhat.com/show_bug.cgi?id=1290170

 app/controllers/report_controller.rb               |  2 -
 app/controllers/report_controller/reports.rb       | 39 +++++-------------
 .../report_controller/reports/editor.rb            | 16 ++------
 .../miq_report_controller/reports/editor_spec.rb   | 47 ++++++++++++++++++++++
 4 files changed, 62 insertions(+), 42 deletions(-)
Comment 4 CFME Bot 2015-12-14 17:01:04 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/ba3e50ad6b813308547c376989f19222a5e4e8b0

commit ba3e50ad6b813308547c376989f19222a5e4e8b0
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Fri Dec 11 12:57:08 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri Dec 11 12:57:08 2015 -0500

    Deleted commented code.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290440
    https://bugzilla.redhat.com/show_bug.cgi?id=1290170

 app/controllers/report_controller/reports/editor.rb | 9 ---------
 1 file changed, 9 deletions(-)
Comment 6 CFME Bot 2015-12-16 15:57:03 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=acff00bc7b192283ae5e025ad7d61cb6e53938d2

commit acff00bc7b192283ae5e025ad7d61cb6e53938d2
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Fri Dec 11 12:20:14 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Dec 14 17:13:02 2015 -0500

    Fixed issue in change tab after Reset is pressed in report editor
    
    - Fixed code to set prefix correctly for tab ids on tabs in Reports editor after Reset button is pressed
    - Added spec test to verify tab ids
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290440
    https://bugzilla.redhat.com/show_bug.cgi?id=1290170
    (cherry picked from commit 8ac9880)

 app/controllers/report_controller.rb               |  2 -
 app/controllers/report_controller/reports.rb       | 39 +++++-------------
 .../report_controller/reports/editor.rb            | 16 ++------
 .../miq_report_controller/reports/editor_spec.rb   | 47 ++++++++++++++++++++++
 4 files changed, 62 insertions(+), 42 deletions(-)
Comment 7 CFME Bot 2015-12-16 15:57:10 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=2fb2d7f773695e92d797e67cbcaa2c90d26457fe

commit 2fb2d7f773695e92d797e67cbcaa2c90d26457fe
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Fri Dec 11 12:57:08 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Dec 14 17:13:12 2015 -0500

    Deleted commented code.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290440
    https://bugzilla.redhat.com/show_bug.cgi?id=1290170
    (cherry picked from commit ba3e50a)

 app/controllers/report_controller/reports/editor.rb | 9 ---------
 1 file changed, 9 deletions(-)
Comment 8 Niyaz Akhtar Ansari 2016-04-18 11:17:51 EDT
Everything works successfully 
Verified in 5.6.0.1-beta2.20160413141124_e25ac0e
Comment 10 errata-xmlrpc 2016-06-29 11:18:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.