Bug 1290440 - UI: Report Editor - After resetting changes on edit screen then trying to change tab throws an error
UI: Report Editor - After resetting changes on edit screen then trying to cha...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.2
Assigned To: Harpreet Kataria
Nandini Chandra
: ZStream
Depends On: 1290170
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 09:14 EST by John Prause
Modified: 2016-02-10 10:24 EST (History)
7 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1290170
Environment:
Last Closed: 2016-02-10 10:24:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Harpreet Kataria 2015-12-11 12:58:12 EST
https://github.com/ManageIQ/manageiq/pull/5804
Comment 2 CFME Bot 2015-12-14 17:00:53 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/8ac9880d457acc56347ef07ae0da6586f8287b4c

commit 8ac9880d457acc56347ef07ae0da6586f8287b4c
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Fri Dec 11 12:20:14 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri Dec 11 12:56:34 2015 -0500

    Fixed issue in change tab after Reset is pressed in report editor
    
    - Fixed code to set prefix correctly for tab ids on tabs in Reports editor after Reset button is pressed
    - Added spec test to verify tab ids
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290440
    https://bugzilla.redhat.com/show_bug.cgi?id=1290170

 app/controllers/report_controller.rb               |  2 -
 app/controllers/report_controller/reports.rb       | 39 +++++-------------
 .../report_controller/reports/editor.rb            | 16 ++------
 .../miq_report_controller/reports/editor_spec.rb   | 47 ++++++++++++++++++++++
 4 files changed, 62 insertions(+), 42 deletions(-)
Comment 3 CFME Bot 2015-12-14 17:01:01 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/ba3e50ad6b813308547c376989f19222a5e4e8b0

commit ba3e50ad6b813308547c376989f19222a5e4e8b0
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Fri Dec 11 12:57:08 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri Dec 11 12:57:08 2015 -0500

    Deleted commented code.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290440
    https://bugzilla.redhat.com/show_bug.cgi?id=1290170

 app/controllers/report_controller/reports/editor.rb | 9 ---------
 1 file changed, 9 deletions(-)
Comment 5 CFME Bot 2015-12-16 15:56:59 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=acff00bc7b192283ae5e025ad7d61cb6e53938d2

commit acff00bc7b192283ae5e025ad7d61cb6e53938d2
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Fri Dec 11 12:20:14 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Dec 14 17:13:02 2015 -0500

    Fixed issue in change tab after Reset is pressed in report editor
    
    - Fixed code to set prefix correctly for tab ids on tabs in Reports editor after Reset button is pressed
    - Added spec test to verify tab ids
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290440
    https://bugzilla.redhat.com/show_bug.cgi?id=1290170
    (cherry picked from commit 8ac9880)

 app/controllers/report_controller.rb               |  2 -
 app/controllers/report_controller/reports.rb       | 39 +++++-------------
 .../report_controller/reports/editor.rb            | 16 ++------
 .../miq_report_controller/reports/editor_spec.rb   | 47 ++++++++++++++++++++++
 4 files changed, 62 insertions(+), 42 deletions(-)
Comment 6 CFME Bot 2015-12-16 15:57:06 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=2fb2d7f773695e92d797e67cbcaa2c90d26457fe

commit 2fb2d7f773695e92d797e67cbcaa2c90d26457fe
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Fri Dec 11 12:57:08 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Dec 14 17:13:12 2015 -0500

    Deleted commented code.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290440
    https://bugzilla.redhat.com/show_bug.cgi?id=1290170
    (cherry picked from commit ba3e50a)

 app/controllers/report_controller/reports/editor.rb | 9 ---------
 1 file changed, 9 deletions(-)
Comment 8 Nandini Chandra 2016-01-18 12:40:06 EST
Verified in 5.5.2.1
Comment 9 errata-xmlrpc 2016-02-10 10:24:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.