Bug 1290175 - cfme cloud-init broken with rhev 3.5.5
cfme cloud-init broken with rhev 3.5.5
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.5.0
All All
high Severity high
: GA
: 5.5.2
Assigned To: Brandon Dunne
Dmitry Misharov
: ZStream
Depends On: 1282618 1328439
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 14:50 EST by John Prause
Modified: 2016-04-19 07:52 EDT (History)
14 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
In the previous version of CloudForms Management Engine, customization of virtual machines provisioned on a Red Hat Enterprise Virtualization Manager (RHEV-M) provider using cloud-init scripts would not work. This was due to a change in the RHEV-M provisioning API that required an additional option in the provisioning request to enable cloud initialization. Additionally, this cloud initialization option works correctly only in RHEV-M versions 3.5.6.0 and later. Cloud initialization for virtual machines provisioned on Red Hat Enterprise Virtualization providers works as expected in the new version of CloudForms Management Engine.
Story Points: ---
Clone Of: 1282618
Environment:
Last Closed: 2016-02-10 10:23:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Marianne Feifer 2016-01-10 19:42:45 EST
B - i'm trying to write doctext for this, but was this actually fixed? Or, is it an issue with RHEVM 3.5?
Comment 2 Brandon Dunne 2016-01-11 11:46:31 EST
Marianne,

In RHEVM 3.5.5.0 a change was made that now requires us to also pass "<use_cloud_init>true</use_cloud_init>" with our request.  However, even when passing this new flag, the cloud-init script is still not used by RHEVM.  This was fixed in RHEVM 3.5.6.0.

Long story short, the changes I made fix cloud-init for RHEVM 3.5.6.0+ by adding the new flag, and cloud-init on RHEV just won't work against RHEVM 3.5.5.X.
Comment 4 Dmitry Misharov 2016-01-25 04:37:07 EST
Verified fixed in 5.5.2.1.20160114044944_395c086.
Cloud-init functionality was tested on RHEVM 3.4.5 and RHEVM 3.5.7. A test cloud-init script was successfully injected and executed into the provisioned VMs.
Comment 5 errata-xmlrpc 2016-02-10 10:23:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.